e41d5cfcea57befa93b932b8c63991b927d143c7
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 4.3
8 %define taglevel 11
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26 Requires: tar, gnupg, sharutils, bzip2, pypcilib
27 Requires: PLCAPI >= 4.3
28
29 # the python code packaged in these are shipped on the node as well
30 Requires: pypcilib pyplnet monitor-runlevelagent
31
32 AutoReqProv: no
33 %define debug_package %{nil}
34
35 %description
36 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
37 nodes.
38
39 %prep
40 %setup -q
41
42 %build
43 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 # Install source so that it can be rebuilt
49 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
50
51 touch bootmanager.sh
52 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
53
54 # This is only required for 2.x bootcds.
55 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 # If run under sudo
61 if [ -n "$SUDO_USER" ] ; then
62     # Allow user to delete the build directory
63     chown -h -R $SUDO_USER .
64     # Some temporary cdroot files like /var/empty/sshd and
65     # /usr/bin/sudo get created with non-readable permissions.
66     find . -not -perm +0600 -exec chmod u+rw {} \;
67     # Allow user to delete the built RPM(s)
68     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
69 fi
70
71 %post
72 cat <<EOF
73 Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
74 PlanetLab private key.
75 EOF
76
77 # NOTE: do not run this agent when installed on a myplc.
78 chkconfig monitor-runlevelagent off
79 chkconfig --del monitor-runlevelagent
80
81 %files
82 %defattr(-,root,root,-)
83 %{_datadir}/%{name}
84 %ghost /var/www/html/boot/bootmanager.sh
85 /var/www/html/boot/uudecode.gz
86
87 %changelog
88 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
89 - raise a single exception for nodes with authentication errors
90 - fix syntax error in MakeInitrd.py
91
92 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
93 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
94 - Removed failboot and install from forced states.
95 - Removed checks for initrd in Validate
96 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
97 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
98
99 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
100 - Special handling for "forcedeth" ethernet NIC.
101
102 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
103 - include a fix for public pl dealing with old/new boot images and root
104 - environments
105
106 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
107 - review selection nodefamily at bootstrapfs install-time
108 - now based on (1) tags (2) nodefamily and (3) defaults
109 - this is required on very old bootcd
110
111 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
112 - Use modprobe module to write out /etc/modprobe.conf.
113
114 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
115 - minor updates - using the new modprobe module *not* in this tag
116
117 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
118 - load device mapper if needed, for centos5-based bootcd variant
119
120 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
121 - renumbered 4.3
122 - New step StartRunLevelAgent
123 - various other tweaks
124
125 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
126 - most of the actual network config job moved to (py)plnet
127 - support for RAWDISK
128 - network interfaces deterministically sorted
129 - does not use nodegroups anymore for getting node arch and other extensions
130 - drop yum-based extensions
131 - debug sshd started as early as possible
132 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
133 - cleaned up (drop support for bootcdv2)
134 - still needs testing
135
136 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
137 - reflects new names from the data model
138
139 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
140 - dont unload cpqphp
141
142 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
143 - changes in the state automaton logic 
144 - root+swap = 7G
145 - usb-key threshhold increased to 17 G
146 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
147
148 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
149 - renamed step InstallBootstrapRPM into InstallBootstrapFS
150 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
151 - import pypcimap rather than pypciscan
152 - initial downlaoding of plc_config made more robust
153 - root and /vservers file systems mounted ext3
154 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
155 - also seems to be using session-based authentication rather than former hmac-based one
156
157 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
158 - usage of wireless attributes fixed and tested
159 - breakpoints cleaned up (no change for production)
160 - less alarming message when floppy does not get unloaded
161
162 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
163 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
164 - removes legacy calls to PlanetLabConf.py 
165 - refrains from unloading floppy 
166 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
167
168 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
169 - Initial build.
170
171 %define module_current_branch 3.2