another angle to the 'try msdos, fallback to gpt' approach
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.0
4 %define taglevel 22
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2, pypcilib
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: PLCAPI >= 5.0
28 # the python code packaged in these are shipped on the node as well
29 Requires: pypcilib pyplnet
30
31 ### avoid having yum complain about updates, as stuff is moving around
32 # plc.d/bootmanager
33 Conflicts: myplc <= 4.3
34 # nodeconfig/boot/*
35 Conflicts: nodeconfig <= 4.3
36
37 AutoReqProv: no
38 %define debug_package %{nil}
39
40 %description
41 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
42 nodes.
43
44 %prep
45 %setup -q
46
47 %build
48 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 # Install source so that it can be rebuilt
54 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
55
56 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
57
58 # formerly in the nodeconfig module
59 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
60 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
61 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
62
63 # formerly in the MyPLC module
64 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 # initialize the boot manager upload area
71 mkdir -p /var/log/bm
72 chown apache:apache /var/log/bm
73 chmod 700 /var/log/bm
74
75 %files
76 %defattr(-,root,root,-)
77 %{_datadir}/%{name}
78 /var/www/html/boot/index.php
79 /var/www/html/boot/upload-bmlog.php
80 /var/www/html/boot/getnodeid.php
81 /etc/plc.d/bootmanager
82
83 %changelog
84 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
85 - bootmanager log clearly states duration of download and extraction of node image
86
87 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
88 - no significant change, just checkpoint as 5.1 is addressing lxc
89
90 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
91 - be more explicit on the node conf_file actually used
92 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
93
94 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
95 - nicer log - was intended for previous tag
96
97 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
98 - {Start,Stop,}RunLevelAgent now ship with bootmanager
99 - new UpdateLastBootOnce
100 - root_size bumped to 14Gb which is more in line with modern h/w
101 - more safely tries to umount /dev/ and /sys
102 - support for raid partitions
103 - mkswap -f
104 - blacklist files from /etc/modprobe.conf/* instead
105
106 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
107 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
108
109 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
110 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
111 - fix for chosing version of parted - for f14
112 - added support for virtio deveices in /dev/vd
113 - fixed scanning of new disks
114 - slightly reviewed logs - default mode is verbose
115 - removed deprecated mkinitrd.sh
116
117 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
118 - Fix problems caused by shell redirection
119
120 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
121 - tag 5.0-13 is broken
122
123 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
124 - Add support for uploading bash_history to a central server for failboot nodes.
125 - Start to use subprocess instead of deprecated popen2 module
126 - Fix typo for VSERVERS_SIZE
127 - Add --allow-missing parameter to support different kernel configs with mkinitrd
128
129 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
130 - Revert "replace deprecated popen2 with subprocess"
131
132 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
133 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
134
135 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
136 - Fix typo
137
138 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
139 - fix typo
140
141 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
142 - disable time/count based filesystem checks
143
144 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
145 - Fix new disk additions to LVM array
146
147 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
148 - bugfix for centos5/python2.4 missing hashlib
149
150 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
151 - check sha1sum of downloaded bootstrapfs
152 - try recovering filesystem errors
153
154 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
155 - nicer initscript now uses 'action' from /etc/init.d/functions
156 - bugfix for nodes with extensions
157
158 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
159 - create /etc/planetlab if missing
160 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
161
162 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
163 - caglar's change to run MkInitrd right before kexec
164 - plus clean up old code
165
166 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
167 - first working version of 5.0:
168 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
169 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
170 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
171
172 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
173 - support for fedora 12
174
175 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
176 - - support for when the node is behind a NAT
177 - - clean up RUN_LEVEL support
178 - - support for early sshd
179
180 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
181 - Add NAT model option for nodes which don't resolve properly.
182
183 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
184 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
185 - BootServerRequest takes the 'VARS' variable to read these values.
186 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
187 - (or any other interface that accepts a POST file)
188 - build.sh bundles cacerts for boot and monitor servers (if present) to
189 - authenticate the UPLOAD_LOG_SCRIPT.
190 - Previously, these certs were re-used from the bootcd, now they are bundled
191 - with BM.  This allows the BM to point to a completely different myplc if
192 - desired, and it is still secure, because the original download is
193 - authenticated.
194
195 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
196 - raise a single exception for nodes with authentication errors
197 - fix syntax error in MakeInitrd.py
198
199 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
200 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
201 - Removed failboot and install from forced states.
202 - Removed checks for initrd in Validate
203 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
204 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
205
206 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
207 - Special handling for "forcedeth" ethernet NIC.
208
209 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
210 - include a fix for public pl dealing with old/new boot images and root
211 - environments
212
213 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
214 - review selection nodefamily at bootstrapfs install-time
215 - now based on (1) tags (2) nodefamily and (3) defaults
216 - this is required on very old bootcd
217
218 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
219 - Use modprobe module to write out /etc/modprobe.conf.
220
221 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
222 - minor updates - using the new modprobe module *not* in this tag
223
224 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
225 - load device mapper if needed, for centos5-based bootcd variant
226
227 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
228 - renumbered 4.3
229 - New step StartRunLevelAgent
230 - various other tweaks
231
232 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
233 - most of the actual network config job moved to (py)plnet
234 - support for RAWDISK
235 - network interfaces deterministically sorted
236 - does not use nodegroups anymore for getting node arch and other extensions
237 - drop yum-based extensions
238 - debug sshd started as early as possible
239 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
240 - cleaned up (drop support for bootcdv2)
241 - still needs testing
242
243 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
244 - reflects new names from the data model
245
246 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
247 - dont unload cpqphp
248
249 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
250 - changes in the state automaton logic 
251 - root+swap = 7G
252 - usb-key threshhold increased to 17 G
253 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
254
255 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
256 - renamed step InstallBootstrapRPM into InstallBootstrapFS
257 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
258 - import pypcimap rather than pypciscan
259 - initial downlaoding of plc_config made more robust
260 - root and /vservers file systems mounted ext3
261 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
262 - also seems to be using session-based authentication rather than former hmac-based one
263
264 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
265 - usage of wireless attributes fixed and tested
266 - breakpoints cleaned up (no change for production)
267 - less alarming message when floppy does not get unloaded
268
269 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
270 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
271 - removes legacy calls to PlanetLabConf.py 
272 - refrains from unloading floppy 
273 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
274
275 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
276 - Initial build.
277
278 %define module_current_branch 4.3