Setting tag bootmanager-5.1-5
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.1
4 %define taglevel 5
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2, pypcilib
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: PLCAPI >= 5.0
28 # the python code packaged in these are shipped on the node as well
29 Requires: pypcilib pyplnet
30
31 ### avoid having yum complain about updates, as stuff is moving around
32 # plc.d/bootmanager
33 Conflicts: myplc <= 4.3
34 # nodeconfig/boot/*
35 Conflicts: nodeconfig <= 4.3
36
37 AutoReqProv: no
38 %define debug_package %{nil}
39
40 %description
41 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
42 nodes.
43
44 %prep
45 %setup -q
46
47 %build
48 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 # Install source so that it can be rebuilt
54 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
55
56 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
57
58 # formerly in the nodeconfig module
59 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
60 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
61 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
62
63 # formerly in the MyPLC module
64 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 # initialize the boot manager upload area
71 mkdir -p /var/log/bm
72 chown apache:apache /var/log/bm
73 chmod 700 /var/log/bm
74
75 %files
76 %defattr(-,root,root,-)
77 %{_datadir}/%{name}
78 /var/www/html/boot/index.php
79 /var/www/html/boot/upload-bmlog.php
80 /var/www/html/boot/getnodeid.php
81 /etc/plc.d/bootmanager
82
83 %changelog
84 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-5
85 - fix for heterogeneous bootimage/nodeimage
86
87 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-4
88 - Turn off WriteModprobeConfig for f18
89 - enable btrfs quota
90 - fix very old ssh DSA key generation
91
92 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
93 - run parted with --script to keep it from hanging
94
95 * Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
96 - pour the 5.0-22 and 5.0-23 features into the lxc mix
97
98 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
99 - added support for disks larger than 2Tb using gpt instead of msdos
100
101 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
102 - bootmanager log clearly states duration of download and extraction of node image
103
104 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
105 - first working draft for dealing with f16 nodes
106 - not expected to work with mainline nodes (use 5.0 for that for now)
107
108 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
109 - no significant change, just checkpoint as 5.1 is addressing lxc
110
111 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
112 - be more explicit on the node conf_file actually used
113 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
114
115 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
116 - nicer log - was intended for previous tag
117
118 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
119 - {Start,Stop,}RunLevelAgent now ship with bootmanager
120 - new UpdateLastBootOnce
121 - root_size bumped to 14Gb which is more in line with modern h/w
122 - more safely tries to umount /dev/ and /sys
123 - support for raid partitions
124 - mkswap -f
125 - blacklist files from /etc/modprobe.conf/* instead
126
127 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
128 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
129
130 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
131 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
132 - fix for chosing version of parted - for f14
133 - added support for virtio deveices in /dev/vd
134 - fixed scanning of new disks
135 - slightly reviewed logs - default mode is verbose
136 - removed deprecated mkinitrd.sh
137
138 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
139 - Fix problems caused by shell redirection
140
141 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
142 - tag 5.0-13 is broken
143
144 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
145 - Add support for uploading bash_history to a central server for failboot nodes.
146 - Start to use subprocess instead of deprecated popen2 module
147 - Fix typo for VSERVERS_SIZE
148 - Add --allow-missing parameter to support different kernel configs with mkinitrd
149
150 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
151 - Revert "replace deprecated popen2 with subprocess"
152
153 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
154 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
155
156 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
157 - Fix typo
158
159 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
160 - fix typo
161
162 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
163 - disable time/count based filesystem checks
164
165 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
166 - Fix new disk additions to LVM array
167
168 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
169 - bugfix for centos5/python2.4 missing hashlib
170
171 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
172 - check sha1sum of downloaded bootstrapfs
173 - try recovering filesystem errors
174
175 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
176 - nicer initscript now uses 'action' from /etc/init.d/functions
177 - bugfix for nodes with extensions
178
179 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
180 - create /etc/planetlab if missing
181 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
182
183 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
184 - caglar's change to run MkInitrd right before kexec
185 - plus clean up old code
186
187 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
188 - first working version of 5.0:
189 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
190 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
191 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
192
193 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
194 - support for fedora 12
195
196 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
197 - - support for when the node is behind a NAT
198 - - clean up RUN_LEVEL support
199 - - support for early sshd
200
201 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
202 - Add NAT model option for nodes which don't resolve properly.
203
204 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
205 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
206 - BootServerRequest takes the 'VARS' variable to read these values.
207 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
208 - (or any other interface that accepts a POST file)
209 - build.sh bundles cacerts for boot and monitor servers (if present) to
210 - authenticate the UPLOAD_LOG_SCRIPT.
211 - Previously, these certs were re-used from the bootcd, now they are bundled
212 - with BM.  This allows the BM to point to a completely different myplc if
213 - desired, and it is still secure, because the original download is
214 - authenticated.
215
216 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
217 - raise a single exception for nodes with authentication errors
218 - fix syntax error in MakeInitrd.py
219
220 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
221 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
222 - Removed failboot and install from forced states.
223 - Removed checks for initrd in Validate
224 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
225 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
226
227 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
228 - Special handling for "forcedeth" ethernet NIC.
229
230 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
231 - include a fix for public pl dealing with old/new boot images and root
232 - environments
233
234 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
235 - review selection nodefamily at bootstrapfs install-time
236 - now based on (1) tags (2) nodefamily and (3) defaults
237 - this is required on very old bootcd
238
239 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
240 - Use modprobe module to write out /etc/modprobe.conf.
241
242 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
243 - minor updates - using the new modprobe module *not* in this tag
244
245 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
246 - load device mapper if needed, for centos5-based bootcd variant
247
248 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
249 - renumbered 4.3
250 - New step StartRunLevelAgent
251 - various other tweaks
252
253 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
254 - most of the actual network config job moved to (py)plnet
255 - support for RAWDISK
256 - network interfaces deterministically sorted
257 - does not use nodegroups anymore for getting node arch and other extensions
258 - drop yum-based extensions
259 - debug sshd started as early as possible
260 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
261 - cleaned up (drop support for bootcdv2)
262 - still needs testing
263
264 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
265 - reflects new names from the data model
266
267 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
268 - dont unload cpqphp
269
270 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
271 - changes in the state automaton logic 
272 - root+swap = 7G
273 - usb-key threshhold increased to 17 G
274 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
275
276 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
277 - renamed step InstallBootstrapRPM into InstallBootstrapFS
278 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
279 - import pypcimap rather than pypciscan
280 - initial downlaoding of plc_config made more robust
281 - root and /vservers file systems mounted ext3
282 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
283 - also seems to be using session-based authentication rather than former hmac-based one
284
285 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
286 - usage of wireless attributes fixed and tested
287 - breakpoints cleaned up (no change for production)
288 - less alarming message when floppy does not get unloaded
289
290 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
291 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
292 - removes legacy calls to PlanetLabConf.py 
293 - refrains from unloading floppy 
294 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
295
296 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
297 - Initial build.
298
299 %define module_current_branch 4.3