iterate
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 4.3
8 %define taglevel 16
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25 BuildArch: noarch
26
27 Requires: tar, gnupg, sharutils, bzip2, pypcilib
28 Requires: PLCAPI >= 4.3
29 # the python code packaged in these are shipped on the node as well
30 Requires: pypcilib pyplnet monitor-runlevelagent
31
32 ### avoid having yum complain about updates, as stuff is moving around
33 # plc.d/bootmanager
34 Conflicts: myplc <= 4.3-37
35 # nodeconfig/boot/*
36 Conflicts: nodeconfig <= 4.3-7
37
38 AutoReqProv: no
39 %define debug_package %{nil}
40
41 %description
42 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
43 nodes.
44
45 %prep
46 %setup -q
47
48 %build
49 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 # Install source so that it can be rebuilt
55 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
56
57 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
58
59 # formerly in the nodeconfig module
60 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
61 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
62
63 # formerly in the MyPLC module
64 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 # signing of botmanager.sh occurs as part of /etc/plc.d/bootmanager
71 # which in turn invokes build.sh
72
73 # NOTE: do not run this agent when installed on a myplc.
74 # xxx - a bit hacky maybe
75 chkconfig monitor-runlevelagent off
76 chkconfig --del monitor-runlevelagent
77
78 %files
79 %defattr(-,root,root,-)
80 %{_datadir}/%{name}
81 /var/www/html/boot/index.php
82 /etc/plc.d/bootmanager
83
84 %changelog
85 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
86 - support for fedora 12
87
88 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
89 - - support for when the node is behind a NAT
90 - - clean up RUN_LEVEL support
91 - - support for early sshd
92
93 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
94 - Add NAT model option for nodes which don't resolve properly.
95
96 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
97 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
98 - BootServerRequest takes the 'VARS' variable to read these values.
99 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
100 - (or any other interface that accepts a POST file)
101 - build.sh bundles cacerts for boot and monitor servers (if present) to
102 - authenticate the UPLOAD_LOG_SCRIPT.
103 - Previously, these certs were re-used from the bootcd, now they are bundled
104 - with BM.  This allows the BM to point to a completely different myplc if
105 - desired, and it is still secure, because the original download is
106 - authenticated.
107
108 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
109 - raise a single exception for nodes with authentication errors
110 - fix syntax error in MakeInitrd.py
111
112 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
113 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
114 - Removed failboot and install from forced states.
115 - Removed checks for initrd in Validate
116 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
117 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
118
119 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
120 - Special handling for "forcedeth" ethernet NIC.
121
122 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
123 - include a fix for public pl dealing with old/new boot images and root
124 - environments
125
126 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
127 - review selection nodefamily at bootstrapfs install-time
128 - now based on (1) tags (2) nodefamily and (3) defaults
129 - this is required on very old bootcd
130
131 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
132 - Use modprobe module to write out /etc/modprobe.conf.
133
134 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
135 - minor updates - using the new modprobe module *not* in this tag
136
137 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
138 - load device mapper if needed, for centos5-based bootcd variant
139
140 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
141 - renumbered 4.3
142 - New step StartRunLevelAgent
143 - various other tweaks
144
145 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
146 - most of the actual network config job moved to (py)plnet
147 - support for RAWDISK
148 - network interfaces deterministically sorted
149 - does not use nodegroups anymore for getting node arch and other extensions
150 - drop yum-based extensions
151 - debug sshd started as early as possible
152 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
153 - cleaned up (drop support for bootcdv2)
154 - still needs testing
155
156 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
157 - reflects new names from the data model
158
159 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
160 - dont unload cpqphp
161
162 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
163 - changes in the state automaton logic 
164 - root+swap = 7G
165 - usb-key threshhold increased to 17 G
166 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
167
168 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
169 - renamed step InstallBootstrapRPM into InstallBootstrapFS
170 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
171 - import pypcimap rather than pypciscan
172 - initial downlaoding of plc_config made more robust
173 - root and /vservers file systems mounted ext3
174 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
175 - also seems to be using session-based authentication rather than former hmac-based one
176
177 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
178 - usage of wireless attributes fixed and tested
179 - breakpoints cleaned up (no change for production)
180 - less alarming message when floppy does not get unloaded
181
182 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
183 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
184 - removes legacy calls to PlanetLabConf.py 
185 - refrains from unloading floppy 
186 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
187
188 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
189 - Initial build.
190
191 %define module_current_branch 3.2