try harder
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 4.3
8 %define taglevel 16
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25 BuildArch: noarch
26
27 Requires: tar, gnupg, sharutils, bzip2, pypcilib
28 Requires: PLCAPI >= 4.3
29 # the python code packaged in these are shipped on the node as well
30 Requires: pypcilib pyplnet monitor-runlevelagent
31
32 # plc.d/bootmanager is moving
33 Conflicts: myplc <= 4.3-37
34 # nodeconfig/boot/index.php is moving
35 Conflicts: nodeconfig <= 4.3-7
36
37 AutoReqProv: no
38 %define debug_package %{nil}
39
40 %description
41 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
42 nodes.
43
44 %prep
45 %setup -q
46
47 %build
48 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 # Install source so that it can be rebuilt
54 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
55
56 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
57
58 # formerly in the nodeconfig module
59 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
60
61 # formerly in the MyPLC module
62 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/pld.c/bootmanager
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 # signing of botmanager.sh occurs as part of plc.d/bootmanager
69
70 # NOTE: do not run this agent when installed on a myplc.
71 # xxx - a bit hacky maybe
72 chkconfig monitor-runlevelagent off
73 chkconfig --del monitor-runlevelagent
74
75 %files
76 %defattr(-,root,root,-)
77 %{_datadir}/%{name}
78 /var/www/html/boot/index.php
79 /etc/pld.c/bootmanager
80
81 %changelog
82 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
83 - support for fedora 12
84
85 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
86 - - support for when the node is behind a NAT
87 - - clean up RUN_LEVEL support
88 - - support for early sshd
89
90 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
91 - Add NAT model option for nodes which don't resolve properly.
92
93 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
94 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
95 - BootServerRequest takes the 'VARS' variable to read these values.
96 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
97 - (or any other interface that accepts a POST file)
98 - build.sh bundles cacerts for boot and monitor servers (if present) to
99 - authenticate the UPLOAD_LOG_SCRIPT.
100 - Previously, these certs were re-used from the bootcd, now they are bundled
101 - with BM.  This allows the BM to point to a completely different myplc if
102 - desired, and it is still secure, because the original download is
103 - authenticated.
104
105 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
106 - raise a single exception for nodes with authentication errors
107 - fix syntax error in MakeInitrd.py
108
109 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
110 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
111 - Removed failboot and install from forced states.
112 - Removed checks for initrd in Validate
113 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
114 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
115
116 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
117 - Special handling for "forcedeth" ethernet NIC.
118
119 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
120 - include a fix for public pl dealing with old/new boot images and root
121 - environments
122
123 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
124 - review selection nodefamily at bootstrapfs install-time
125 - now based on (1) tags (2) nodefamily and (3) defaults
126 - this is required on very old bootcd
127
128 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
129 - Use modprobe module to write out /etc/modprobe.conf.
130
131 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
132 - minor updates - using the new modprobe module *not* in this tag
133
134 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
135 - load device mapper if needed, for centos5-based bootcd variant
136
137 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
138 - renumbered 4.3
139 - New step StartRunLevelAgent
140 - various other tweaks
141
142 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
143 - most of the actual network config job moved to (py)plnet
144 - support for RAWDISK
145 - network interfaces deterministically sorted
146 - does not use nodegroups anymore for getting node arch and other extensions
147 - drop yum-based extensions
148 - debug sshd started as early as possible
149 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
150 - cleaned up (drop support for bootcdv2)
151 - still needs testing
152
153 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
154 - reflects new names from the data model
155
156 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
157 - dont unload cpqphp
158
159 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
160 - changes in the state automaton logic 
161 - root+swap = 7G
162 - usb-key threshhold increased to 17 G
163 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
164
165 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
166 - renamed step InstallBootstrapRPM into InstallBootstrapFS
167 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
168 - import pypcimap rather than pypciscan
169 - initial downlaoding of plc_config made more robust
170 - root and /vservers file systems mounted ext3
171 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
172 - also seems to be using session-based authentication rather than former hmac-based one
173
174 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
175 - usage of wireless attributes fixed and tested
176 - breakpoints cleaned up (no change for production)
177 - less alarming message when floppy does not get unloaded
178
179 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
180 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
181 - removes legacy calls to PlanetLabConf.py 
182 - refrains from unloading floppy 
183 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
184
185 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
186 - Initial build.
187
188 %define module_current_branch 3.2