Setting tag bootmanager-5.0-15
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 5.0
8 %define taglevel 15
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25 BuildArch: noarch
26
27 Requires: tar, gnupg, sharutils, bzip2, pypcilib
28 # need the apache user at install-time
29 Requires: httpd 
30
31 Requires: PLCAPI >= 5.0
32 # the python code packaged in these are shipped on the node as well
33 Requires: pypcilib pyplnet monitor-runlevelagent
34
35 ### avoid having yum complain about updates, as stuff is moving around
36 # plc.d/bootmanager
37 Conflicts: myplc <= 4.3
38 # nodeconfig/boot/*
39 Conflicts: nodeconfig <= 4.3
40
41 AutoReqProv: no
42 %define debug_package %{nil}
43
44 %description
45 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
46 nodes.
47
48 %prep
49 %setup -q
50
51 %build
52 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 # Install source so that it can be rebuilt
58 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
59
60 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
61
62 # formerly in the nodeconfig module
63 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
64 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
65 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
66
67 # formerly in the MyPLC module
68 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 # initialize the boot manager upload area
75 mkdir -p /var/log/bm
76 chown apache:apache /var/log/bm
77 chmod 700 /var/log/bm
78
79 # NOTE: do not run this agent when installed on a myplc.
80 # xxx - a bit hacky maybe
81 chkconfig monitor-runlevelagent off
82 chkconfig --del monitor-runlevelagent
83
84 %files
85 %defattr(-,root,root,-)
86 %{_datadir}/%{name}
87 /var/www/html/boot/index.php
88 /var/www/html/boot/upload-bmlog.php
89 /var/www/html/boot/getnodeid.php
90 /etc/plc.d/bootmanager
91
92 %changelog
93 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
94 - Fix problems caused by shell redirection
95
96 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
97 - tag 5.0-13 is broken
98
99 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
100 - Add support for uploading bash_history to a central server for failboot nodes.
101 - Start to use subprocess instead of deprecated popen2 module
102 - Fix typo for VSERVERS_SIZE
103 - Add --allow-missing parameter to support different kernel configs with mkinitrd
104
105 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
106 - Revert "replace deprecated popen2 with subprocess"
107
108 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
109 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
110
111 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
112 - Fix typo
113
114 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
115 - fix typo
116
117 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
118 - disable time/count based filesystem checks
119
120 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
121 - Fix new disk additions to LVM array
122
123 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
124 - bugfix for centos5/python2.4 missing hashlib
125
126 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
127 - check sha1sum of downloaded bootstrapfs
128 - try recovering filesystem errors
129
130 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
131 - nicer initscript now uses 'action' from /etc/init.d/functions
132 - bugfix for nodes with extensions
133
134 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
135 - create /etc/planetlab if missing
136 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
137
138 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
139 - caglar's change to run MkInitrd right before kexec
140 - plus clean up old code
141
142 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
143 - first working version of 5.0:
144 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
145 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
146 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
147
148 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
149 - support for fedora 12
150
151 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
152 - - support for when the node is behind a NAT
153 - - clean up RUN_LEVEL support
154 - - support for early sshd
155
156 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
157 - Add NAT model option for nodes which don't resolve properly.
158
159 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
160 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
161 - BootServerRequest takes the 'VARS' variable to read these values.
162 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
163 - (or any other interface that accepts a POST file)
164 - build.sh bundles cacerts for boot and monitor servers (if present) to
165 - authenticate the UPLOAD_LOG_SCRIPT.
166 - Previously, these certs were re-used from the bootcd, now they are bundled
167 - with BM.  This allows the BM to point to a completely different myplc if
168 - desired, and it is still secure, because the original download is
169 - authenticated.
170
171 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
172 - raise a single exception for nodes with authentication errors
173 - fix syntax error in MakeInitrd.py
174
175 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
176 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
177 - Removed failboot and install from forced states.
178 - Removed checks for initrd in Validate
179 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
180 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
181
182 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
183 - Special handling for "forcedeth" ethernet NIC.
184
185 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
186 - include a fix for public pl dealing with old/new boot images and root
187 - environments
188
189 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
190 - review selection nodefamily at bootstrapfs install-time
191 - now based on (1) tags (2) nodefamily and (3) defaults
192 - this is required on very old bootcd
193
194 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
195 - Use modprobe module to write out /etc/modprobe.conf.
196
197 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
198 - minor updates - using the new modprobe module *not* in this tag
199
200 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
201 - load device mapper if needed, for centos5-based bootcd variant
202
203 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
204 - renumbered 4.3
205 - New step StartRunLevelAgent
206 - various other tweaks
207
208 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
209 - most of the actual network config job moved to (py)plnet
210 - support for RAWDISK
211 - network interfaces deterministically sorted
212 - does not use nodegroups anymore for getting node arch and other extensions
213 - drop yum-based extensions
214 - debug sshd started as early as possible
215 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
216 - cleaned up (drop support for bootcdv2)
217 - still needs testing
218
219 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
220 - reflects new names from the data model
221
222 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
223 - dont unload cpqphp
224
225 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
226 - changes in the state automaton logic 
227 - root+swap = 7G
228 - usb-key threshhold increased to 17 G
229 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
230
231 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
232 - renamed step InstallBootstrapRPM into InstallBootstrapFS
233 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
234 - import pypcimap rather than pypciscan
235 - initial downlaoding of plc_config made more robust
236 - root and /vservers file systems mounted ext3
237 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
238 - also seems to be using session-based authentication rather than former hmac-based one
239
240 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
241 - usage of wireless attributes fixed and tested
242 - breakpoints cleaned up (no change for production)
243 - less alarming message when floppy does not get unloaded
244
245 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
246 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
247 - removes legacy calls to PlanetLabConf.py 
248 - refrains from unloading floppy 
249 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
250
251 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
252 - Initial build.
253
254 %define module_current_branch 4.3