disable runlevelagent when it is installed by bootmanager as part of myplc.
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 4.3
8 %define taglevel 9
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26 Requires: tar, gnupg, sharutils, bzip2, pypcilib
27 Requires: PLCAPI >= 4.3
28
29 # the python code packaged in these are shipped on the node as well
30 Requires: pypcilib pyplnet monitor-runlevelagent
31
32 AutoReqProv: no
33 %define debug_package %{nil}
34
35 %description
36 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
37 nodes.
38
39 %prep
40 %setup -q
41
42 %build
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 # Install source so that it can be rebuilt
48 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
49
50 touch bootmanager.sh
51 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
52
53 # This is only required for 2.x bootcds.
54 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 # If run under sudo
60 if [ -n "$SUDO_USER" ] ; then
61     # Allow user to delete the build directory
62     chown -h -R $SUDO_USER .
63     # Some temporary cdroot files like /var/empty/sshd and
64     # /usr/bin/sudo get created with non-readable permissions.
65     find . -not -perm +0600 -exec chmod u+rw {} \;
66     # Allow user to delete the built RPM(s)
67     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
68 fi
69
70 %post
71 cat <<EOF
72 Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
73 PlanetLab private key.
74 EOF
75
76 # NOTE: do not run this agent when installed on a myplc.
77 chkconfig monitor-runlevelagent off
78 chkconfig --del monitor-runlevelagent
79
80 %files
81 %defattr(-,root,root,-)
82 %{_datadir}/%{name}
83 %ghost /var/www/html/boot/bootmanager.sh
84 /var/www/html/boot/uudecode.gz
85
86 %changelog
87 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
88 - Special handling for "forcedeth" ethernet NIC.
89
90 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
91 - include a fix for public pl dealing with old/new boot images and root
92 - environments
93
94 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
95 - review selection nodefamily at bootstrapfs install-time
96 - now based on (1) tags (2) nodefamily and (3) defaults
97 - this is required on very old bootcd
98
99 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
100 - Use modprobe module to write out /etc/modprobe.conf.
101
102 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
103 - minor updates - using the new modprobe module *not* in this tag
104
105 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
106 - load device mapper if needed, for centos5-based bootcd variant
107
108 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
109 - renumbered 4.3
110 - New step StartRunLevelAgent
111 - various other tweaks
112
113 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
114 - most of the actual network config job moved to (py)plnet
115 - support for RAWDISK
116 - network interfaces deterministically sorted
117 - does not use nodegroups anymore for getting node arch and other extensions
118 - drop yum-based extensions
119 - debug sshd started as early as possible
120 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
121 - cleaned up (drop support for bootcdv2)
122 - still needs testing
123
124 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
125 - reflects new names from the data model
126
127 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
128 - dont unload cpqphp
129
130 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
131 - changes in the state automaton logic 
132 - root+swap = 7G
133 - usb-key threshhold increased to 17 G
134 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
135
136 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
137 - renamed step InstallBootstrapRPM into InstallBootstrapFS
138 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
139 - import pypcimap rather than pypciscan
140 - initial downlaoding of plc_config made more robust
141 - root and /vservers file systems mounted ext3
142 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
143 - also seems to be using session-based authentication rather than former hmac-based one
144
145 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
146 - usage of wireless attributes fixed and tested
147 - breakpoints cleaned up (no change for production)
148 - less alarming message when floppy does not get unloaded
149
150 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
151 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
152 - removes legacy calls to PlanetLabConf.py 
153 - refrains from unloading floppy 
154 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
155
156 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
157 - Initial build.
158
159 %define module_current_branch 3.2