Branch 5.0 for module BootManager created (as new trunk) from tag BootManager-4.3-16
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 5.0
8 %define taglevel 0
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25 BuildArch: noarch
26
27 Requires: tar, gnupg, sharutils, bzip2, pypcilib
28 Requires: PLCAPI >= 4.3
29 # the python code packaged in these are shipped on the node as well
30 Requires: pypcilib pyplnet monitor-runlevelagent
31
32 ### avoid having yum complain about updates, as stuff is moving around
33 # plc.d/bootmanager
34 Conflicts: myplc <= 4.3-37
35 # nodeconfig/boot/*
36 Conflicts: nodeconfig <= 4.3-7
37
38 AutoReqProv: no
39 %define debug_package %{nil}
40
41 %description
42 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
43 nodes.
44
45 %prep
46 %setup -q
47
48 %build
49 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 # Install source so that it can be rebuilt
55 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
56
57 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
58
59 # formerly in the nodeconfig module
60 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
61 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
62 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
63
64 # formerly in the MyPLC module
65 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 # signing of botmanager.sh occurs as part of /etc/plc.d/bootmanager
72 # which in turn invokes build.sh
73
74 # NOTE: do not run this agent when installed on a myplc.
75 # xxx - a bit hacky maybe
76 chkconfig monitor-runlevelagent off
77 chkconfig --del monitor-runlevelagent
78
79 %files
80 %defattr(-,root,root,-)
81 %{_datadir}/%{name}
82 /var/www/html/boot/index.php
83 /var/www/html/boot/upload-bmlog.php
84 /var/www/html/boot/getnodeid.php
85 /etc/plc.d/bootmanager
86
87 %changelog
88 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
89 - support for fedora 12
90
91 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
92 - - support for when the node is behind a NAT
93 - - clean up RUN_LEVEL support
94 - - support for early sshd
95
96 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
97 - Add NAT model option for nodes which don't resolve properly.
98
99 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
100 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
101 - BootServerRequest takes the 'VARS' variable to read these values.
102 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
103 - (or any other interface that accepts a POST file)
104 - build.sh bundles cacerts for boot and monitor servers (if present) to
105 - authenticate the UPLOAD_LOG_SCRIPT.
106 - Previously, these certs were re-used from the bootcd, now they are bundled
107 - with BM.  This allows the BM to point to a completely different myplc if
108 - desired, and it is still secure, because the original download is
109 - authenticated.
110
111 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
112 - raise a single exception for nodes with authentication errors
113 - fix syntax error in MakeInitrd.py
114
115 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
116 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
117 - Removed failboot and install from forced states.
118 - Removed checks for initrd in Validate
119 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
120 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
121
122 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
123 - Special handling for "forcedeth" ethernet NIC.
124
125 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
126 - include a fix for public pl dealing with old/new boot images and root
127 - environments
128
129 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
130 - review selection nodefamily at bootstrapfs install-time
131 - now based on (1) tags (2) nodefamily and (3) defaults
132 - this is required on very old bootcd
133
134 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
135 - Use modprobe module to write out /etc/modprobe.conf.
136
137 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
138 - minor updates - using the new modprobe module *not* in this tag
139
140 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
141 - load device mapper if needed, for centos5-based bootcd variant
142
143 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
144 - renumbered 4.3
145 - New step StartRunLevelAgent
146 - various other tweaks
147
148 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
149 - most of the actual network config job moved to (py)plnet
150 - support for RAWDISK
151 - network interfaces deterministically sorted
152 - does not use nodegroups anymore for getting node arch and other extensions
153 - drop yum-based extensions
154 - debug sshd started as early as possible
155 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
156 - cleaned up (drop support for bootcdv2)
157 - still needs testing
158
159 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
160 - reflects new names from the data model
161
162 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
163 - dont unload cpqphp
164
165 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
166 - changes in the state automaton logic 
167 - root+swap = 7G
168 - usb-key threshhold increased to 17 G
169 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
170
171 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
172 - renamed step InstallBootstrapRPM into InstallBootstrapFS
173 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
174 - import pypcimap rather than pypciscan
175 - initial downlaoding of plc_config made more robust
176 - root and /vservers file systems mounted ext3
177 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
178 - also seems to be using session-based authentication rather than former hmac-based one
179
180 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
181 - usage of wireless attributes fixed and tested
182 - breakpoints cleaned up (no change for production)
183 - less alarming message when floppy does not get unloaded
184
185 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
186 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
187 - removes legacy calls to PlanetLabConf.py 
188 - refrains from unloading floppy 
189 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
190
191 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
192 - Initial build.
193
194 %define module_current_branch 4.3