Setting tag BootManager-5.0-6
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 5.0
8 %define taglevel 6
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25 BuildArch: noarch
26
27 Requires: tar, gnupg, sharutils, bzip2, pypcilib
28 # need the apache user at install-time
29 Requires: httpd 
30
31 Requires: PLCAPI >= 5.0
32 # the python code packaged in these are shipped on the node as well
33 Requires: pypcilib pyplnet monitor-runlevelagent
34
35 ### avoid having yum complain about updates, as stuff is moving around
36 # plc.d/bootmanager
37 Conflicts: myplc <= 4.3
38 # nodeconfig/boot/*
39 Conflicts: nodeconfig <= 4.3
40
41 AutoReqProv: no
42 %define debug_package %{nil}
43
44 %description
45 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
46 nodes.
47
48 %prep
49 %setup -q
50
51 %build
52 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 # Install source so that it can be rebuilt
58 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
59
60 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
61
62 # formerly in the nodeconfig module
63 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
64 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
65 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
66
67 # formerly in the MyPLC module
68 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 # initialize the boot manager upload area
75 mkdir -p /var/log/bm
76 chown apache:apache /var/log/bm
77 chmod 700 /var/log/bm
78
79 # NOTE: do not run this agent when installed on a myplc.
80 # xxx - a bit hacky maybe
81 chkconfig monitor-runlevelagent off
82 chkconfig --del monitor-runlevelagent
83
84 %files
85 %defattr(-,root,root,-)
86 %{_datadir}/%{name}
87 /var/www/html/boot/index.php
88 /var/www/html/boot/upload-bmlog.php
89 /var/www/html/boot/getnodeid.php
90 /etc/plc.d/bootmanager
91
92 %changelog
93 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
94 - bugfix for centos5/python2.4 missing hashlib
95
96 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
97 - check sha1sum of downloaded bootstrapfs
98 - try recovering filesystem errors
99
100 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
101 - nicer initscript now uses 'action' from /etc/init.d/functions
102 - bugfix for nodes with extensions
103
104 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
105 - create /etc/planetlab if missing
106 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
107
108 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
109 - caglar's change to run MkInitrd right before kexec
110 - plus clean up old code
111
112 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
113 - first working version of 5.0:
114 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
115 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
116 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
117
118 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
119 - support for fedora 12
120
121 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
122 - - support for when the node is behind a NAT
123 - - clean up RUN_LEVEL support
124 - - support for early sshd
125
126 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
127 - Add NAT model option for nodes which don't resolve properly.
128
129 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
130 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
131 - BootServerRequest takes the 'VARS' variable to read these values.
132 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
133 - (or any other interface that accepts a POST file)
134 - build.sh bundles cacerts for boot and monitor servers (if present) to
135 - authenticate the UPLOAD_LOG_SCRIPT.
136 - Previously, these certs were re-used from the bootcd, now they are bundled
137 - with BM.  This allows the BM to point to a completely different myplc if
138 - desired, and it is still secure, because the original download is
139 - authenticated.
140
141 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
142 - raise a single exception for nodes with authentication errors
143 - fix syntax error in MakeInitrd.py
144
145 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
146 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
147 - Removed failboot and install from forced states.
148 - Removed checks for initrd in Validate
149 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
150 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
151
152 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
153 - Special handling for "forcedeth" ethernet NIC.
154
155 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
156 - include a fix for public pl dealing with old/new boot images and root
157 - environments
158
159 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
160 - review selection nodefamily at bootstrapfs install-time
161 - now based on (1) tags (2) nodefamily and (3) defaults
162 - this is required on very old bootcd
163
164 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
165 - Use modprobe module to write out /etc/modprobe.conf.
166
167 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
168 - minor updates - using the new modprobe module *not* in this tag
169
170 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
171 - load device mapper if needed, for centos5-based bootcd variant
172
173 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
174 - renumbered 4.3
175 - New step StartRunLevelAgent
176 - various other tweaks
177
178 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
179 - most of the actual network config job moved to (py)plnet
180 - support for RAWDISK
181 - network interfaces deterministically sorted
182 - does not use nodegroups anymore for getting node arch and other extensions
183 - drop yum-based extensions
184 - debug sshd started as early as possible
185 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
186 - cleaned up (drop support for bootcdv2)
187 - still needs testing
188
189 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
190 - reflects new names from the data model
191
192 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
193 - dont unload cpqphp
194
195 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
196 - changes in the state automaton logic 
197 - root+swap = 7G
198 - usb-key threshhold increased to 17 G
199 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
200
201 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
202 - renamed step InstallBootstrapRPM into InstallBootstrapFS
203 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
204 - import pypcimap rather than pypciscan
205 - initial downlaoding of plc_config made more robust
206 - root and /vservers file systems mounted ext3
207 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
208 - also seems to be using session-based authentication rather than former hmac-based one
209
210 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
211 - usage of wireless attributes fixed and tested
212 - breakpoints cleaned up (no change for production)
213 - less alarming message when floppy does not get unloaded
214
215 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
216 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
217 - removes legacy calls to PlanetLabConf.py 
218 - refrains from unloading floppy 
219 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
220
221 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
222 - Initial build.
223
224 %define module_current_branch 4.3