drop uudecode
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{_arch}
7
8 %define name bootmanager-%{nodefamily}
9 %define version 4.3
10 %define taglevel 16
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Vendor: PlanetLab
15 Packager: PlanetLab Central <support@planet-lab.org>
16 Distribution: PlanetLab %{plrelease}
17 URL: %(echo %{url} | cut -d ' ' -f 2)
18
19 Summary: The PlanetLab Boot Manager
20 Name: %{name}
21 Version: %{version}
22 Release: %{release}
23 License: BSD
24 Group: System Environment/Base
25 Source0: %{name}-%{version}.tar.gz
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
27 BuildArch: noarch
28
29 Requires: tar, gnupg, sharutils, bzip2, pypcilib
30 Requires: PLCAPI >= 4.3
31 # the python code packaged in these are shipped on the node as well
32 Requires: pypcilib pyplnet monitor-runlevelagent
33
34 # plc.d/bootmanager is moving
35 Conflicts: myplc <= 4.3.37
36 # nodeconfig/boot/index.php is moving
37 Conflicts: nodeconfig <= 4.3.7
38
39 AutoReqProv: no
40 %define debug_package %{nil}
41
42 %description
43 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
44 nodes.
45
46 %prep
47 %setup -q
48
49 %build
50 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 # Install source so that it can be rebuilt
56 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
57
58 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
59
60 # formerly in the nodeconfig module
61 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
62
63 # formerly in the MyPLC module
64 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/pld.c/bootmanager
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 # signing of botmanager.sh occurs as part of plc.d/bootmanager
71
72 # NOTE: do not run this agent when installed on a myplc.
73 # xxx - a bit hacky maybe
74 chkconfig monitor-runlevelagent off
75 chkconfig --del monitor-runlevelagent
76
77 %files
78 %defattr(-,root,root,-)
79 %{_datadir}/%{name}
80 /var/www/html/boot/index.php
81 /etc/pld.c/bootmanager
82
83 %changelog
84 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
85 - support for fedora 12
86
87 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
88 - - support for when the node is behind a NAT
89 - - clean up RUN_LEVEL support
90 - - support for early sshd
91
92 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
93 - Add NAT model option for nodes which don't resolve properly.
94
95 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
96 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
97 - BootServerRequest takes the 'VARS' variable to read these values.
98 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
99 - (or any other interface that accepts a POST file)
100 - build.sh bundles cacerts for boot and monitor servers (if present) to
101 - authenticate the UPLOAD_LOG_SCRIPT.
102 - Previously, these certs were re-used from the bootcd, now they are bundled
103 - with BM.  This allows the BM to point to a completely different myplc if
104 - desired, and it is still secure, because the original download is
105 - authenticated.
106
107 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
108 - raise a single exception for nodes with authentication errors
109 - fix syntax error in MakeInitrd.py
110
111 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
112 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
113 - Removed failboot and install from forced states.
114 - Removed checks for initrd in Validate
115 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
116 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
117
118 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
119 - Special handling for "forcedeth" ethernet NIC.
120
121 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
122 - include a fix for public pl dealing with old/new boot images and root
123 - environments
124
125 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
126 - review selection nodefamily at bootstrapfs install-time
127 - now based on (1) tags (2) nodefamily and (3) defaults
128 - this is required on very old bootcd
129
130 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
131 - Use modprobe module to write out /etc/modprobe.conf.
132
133 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
134 - minor updates - using the new modprobe module *not* in this tag
135
136 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
137 - load device mapper if needed, for centos5-based bootcd variant
138
139 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
140 - renumbered 4.3
141 - New step StartRunLevelAgent
142 - various other tweaks
143
144 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
145 - most of the actual network config job moved to (py)plnet
146 - support for RAWDISK
147 - network interfaces deterministically sorted
148 - does not use nodegroups anymore for getting node arch and other extensions
149 - drop yum-based extensions
150 - debug sshd started as early as possible
151 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
152 - cleaned up (drop support for bootcdv2)
153 - still needs testing
154
155 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
156 - reflects new names from the data model
157
158 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
159 - dont unload cpqphp
160
161 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
162 - changes in the state automaton logic 
163 - root+swap = 7G
164 - usb-key threshhold increased to 17 G
165 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
166
167 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
168 - renamed step InstallBootstrapRPM into InstallBootstrapFS
169 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
170 - import pypcimap rather than pypciscan
171 - initial downlaoding of plc_config made more robust
172 - root and /vservers file systems mounted ext3
173 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
174 - also seems to be using session-based authentication rather than former hmac-based one
175
176 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
177 - usage of wireless attributes fixed and tested
178 - breakpoints cleaned up (no change for production)
179 - less alarming message when floppy does not get unloaded
180
181 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
182 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
183 - removes legacy calls to PlanetLabConf.py 
184 - refrains from unloading floppy 
185 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
186
187 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
188 - Initial build.
189
190 %define module_current_branch 3.2