Tagging module BootManager - BootManager-4.3-9
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 4.3
8 %define taglevel 9
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26 Requires: tar, gnupg, sharutils, bzip2, pypcilib
27 Requires: PLCAPI >= 4.3
28
29 # the python code packaged in these are shipped on the node as well
30 Requires: pypcilib pyplnet monitor-runlevelagent
31
32 AutoReqProv: no
33 %define debug_package %{nil}
34
35 %description
36 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
37 nodes.
38
39 %prep
40 %setup -q
41
42 %build
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 # Install source so that it can be rebuilt
48 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
49
50 touch bootmanager.sh
51 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
52
53 # This is only required for 2.x bootcds.
54 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 # If run under sudo
60 if [ -n "$SUDO_USER" ] ; then
61     # Allow user to delete the build directory
62     chown -h -R $SUDO_USER .
63     # Some temporary cdroot files like /var/empty/sshd and
64     # /usr/bin/sudo get created with non-readable permissions.
65     find . -not -perm +0600 -exec chmod u+rw {} \;
66     # Allow user to delete the built RPM(s)
67     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
68 fi
69
70 %post
71 cat <<EOF
72 Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
73 PlanetLab private key.
74 EOF
75
76 %files
77 %defattr(-,root,root,-)
78 %{_datadir}/%{name}
79 %ghost /var/www/html/boot/bootmanager.sh
80 /var/www/html/boot/uudecode.gz
81
82 %changelog
83 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
84 - Special handling for "forcedeth" ethernet NIC.
85
86 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
87 - include a fix for public pl dealing with old/new boot images and root
88 - environments
89
90 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
91 - review selection nodefamily at bootstrapfs install-time
92 - now based on (1) tags (2) nodefamily and (3) defaults
93 - this is required on very old bootcd
94
95 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
96 - Use modprobe module to write out /etc/modprobe.conf.
97
98 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
99 - minor updates - using the new modprobe module *not* in this tag
100
101 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
102 - load device mapper if needed, for centos5-based bootcd variant
103
104 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
105 - renumbered 4.3
106 - New step StartRunLevelAgent
107 - various other tweaks
108
109 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
110 - most of the actual network config job moved to (py)plnet
111 - support for RAWDISK
112 - network interfaces deterministically sorted
113 - does not use nodegroups anymore for getting node arch and other extensions
114 - drop yum-based extensions
115 - debug sshd started as early as possible
116 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
117 - cleaned up (drop support for bootcdv2)
118 - still needs testing
119
120 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
121 - reflects new names from the data model
122
123 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
124 - dont unload cpqphp
125
126 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
127 - changes in the state automaton logic 
128 - root+swap = 7G
129 - usb-key threshhold increased to 17 G
130 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
131
132 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
133 - renamed step InstallBootstrapRPM into InstallBootstrapFS
134 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
135 - import pypcimap rather than pypciscan
136 - initial downlaoding of plc_config made more robust
137 - root and /vservers file systems mounted ext3
138 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
139 - also seems to be using session-based authentication rather than former hmac-based one
140
141 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
142 - usage of wireless attributes fixed and tested
143 - breakpoints cleaned up (no change for production)
144 - less alarming message when floppy does not get unloaded
145
146 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
147 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
148 - removes legacy calls to PlanetLabConf.py 
149 - refrains from unloading floppy 
150 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
151
152 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
153 - Initial build.
154
155 %define module_current_branch 3.2