Setting tag bootmanager-5.0-18
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.0
4 %define taglevel 18
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2, pypcilib
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: PLCAPI >= 5.0
28 # the python code packaged in these are shipped on the node as well
29 Requires: pypcilib pyplnet
30
31 ### avoid having yum complain about updates, as stuff is moving around
32 # plc.d/bootmanager
33 Conflicts: myplc <= 4.3
34 # nodeconfig/boot/*
35 Conflicts: nodeconfig <= 4.3
36
37 AutoReqProv: no
38 %define debug_package %{nil}
39
40 %description
41 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
42 nodes.
43
44 %prep
45 %setup -q
46
47 %build
48 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 # Install source so that it can be rebuilt
54 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
55
56 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
57
58 # formerly in the nodeconfig module
59 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
60 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
61 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
62
63 # formerly in the MyPLC module
64 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 # initialize the boot manager upload area
71 mkdir -p /var/log/bm
72 chown apache:apache /var/log/bm
73 chmod 700 /var/log/bm
74
75 %files
76 %defattr(-,root,root,-)
77 %{_datadir}/%{name}
78 /var/www/html/boot/index.php
79 /var/www/html/boot/upload-bmlog.php
80 /var/www/html/boot/getnodeid.php
81 /etc/plc.d/bootmanager
82
83 %changelog
84 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
85 - {Start,Stop,}RunLevelAgent now ship with bootmanager
86 - new UpdateLastBootOnce
87 - root_size bumped to 14Gb which is more in line with modern h/w
88 - more safely tries to umount /dev/ and /sys
89 - support for raid partitions
90 - mkswap -f
91 - blacklist files from /etc/modprobe.conf/* instead
92
93 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
94 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
95
96 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
97 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
98 - fix for chosing version of parted - for f14
99 - added support for virtio deveices in /dev/vd
100 - fixed scanning of new disks
101 - slightly reviewed logs - default mode is verbose
102 - removed deprecated mkinitrd.sh
103
104 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
105 - Fix problems caused by shell redirection
106
107 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
108 - tag 5.0-13 is broken
109
110 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
111 - Add support for uploading bash_history to a central server for failboot nodes.
112 - Start to use subprocess instead of deprecated popen2 module
113 - Fix typo for VSERVERS_SIZE
114 - Add --allow-missing parameter to support different kernel configs with mkinitrd
115
116 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
117 - Revert "replace deprecated popen2 with subprocess"
118
119 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
120 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
121
122 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
123 - Fix typo
124
125 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
126 - fix typo
127
128 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
129 - disable time/count based filesystem checks
130
131 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
132 - Fix new disk additions to LVM array
133
134 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
135 - bugfix for centos5/python2.4 missing hashlib
136
137 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
138 - check sha1sum of downloaded bootstrapfs
139 - try recovering filesystem errors
140
141 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
142 - nicer initscript now uses 'action' from /etc/init.d/functions
143 - bugfix for nodes with extensions
144
145 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
146 - create /etc/planetlab if missing
147 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
148
149 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
150 - caglar's change to run MkInitrd right before kexec
151 - plus clean up old code
152
153 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
154 - first working version of 5.0:
155 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
156 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
157 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
158
159 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
160 - support for fedora 12
161
162 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
163 - - support for when the node is behind a NAT
164 - - clean up RUN_LEVEL support
165 - - support for early sshd
166
167 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
168 - Add NAT model option for nodes which don't resolve properly.
169
170 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
171 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
172 - BootServerRequest takes the 'VARS' variable to read these values.
173 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
174 - (or any other interface that accepts a POST file)
175 - build.sh bundles cacerts for boot and monitor servers (if present) to
176 - authenticate the UPLOAD_LOG_SCRIPT.
177 - Previously, these certs were re-used from the bootcd, now they are bundled
178 - with BM.  This allows the BM to point to a completely different myplc if
179 - desired, and it is still secure, because the original download is
180 - authenticated.
181
182 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
183 - raise a single exception for nodes with authentication errors
184 - fix syntax error in MakeInitrd.py
185
186 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
187 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
188 - Removed failboot and install from forced states.
189 - Removed checks for initrd in Validate
190 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
191 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
192
193 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
194 - Special handling for "forcedeth" ethernet NIC.
195
196 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
197 - include a fix for public pl dealing with old/new boot images and root
198 - environments
199
200 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
201 - review selection nodefamily at bootstrapfs install-time
202 - now based on (1) tags (2) nodefamily and (3) defaults
203 - this is required on very old bootcd
204
205 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
206 - Use modprobe module to write out /etc/modprobe.conf.
207
208 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
209 - minor updates - using the new modprobe module *not* in this tag
210
211 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
212 - load device mapper if needed, for centos5-based bootcd variant
213
214 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
215 - renumbered 4.3
216 - New step StartRunLevelAgent
217 - various other tweaks
218
219 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
220 - most of the actual network config job moved to (py)plnet
221 - support for RAWDISK
222 - network interfaces deterministically sorted
223 - does not use nodegroups anymore for getting node arch and other extensions
224 - drop yum-based extensions
225 - debug sshd started as early as possible
226 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
227 - cleaned up (drop support for bootcdv2)
228 - still needs testing
229
230 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
231 - reflects new names from the data model
232
233 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
234 - dont unload cpqphp
235
236 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
237 - changes in the state automaton logic 
238 - root+swap = 7G
239 - usb-key threshhold increased to 17 G
240 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
241
242 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
243 - renamed step InstallBootstrapRPM into InstallBootstrapFS
244 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
245 - import pypcimap rather than pypciscan
246 - initial downlaoding of plc_config made more robust
247 - root and /vservers file systems mounted ext3
248 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
249 - also seems to be using session-based authentication rather than former hmac-based one
250
251 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
252 - usage of wireless attributes fixed and tested
253 - breakpoints cleaned up (no change for production)
254 - less alarming message when floppy does not get unloaded
255
256 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
257 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
258 - removes legacy calls to PlanetLabConf.py 
259 - refrains from unloading floppy 
260 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
261
262 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
263 - Initial build.
264
265 %define module_current_branch 4.3