Add Runlevelagent to BM. Add UpdateLastBootOnce() to record last_* in DB.
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.0
4 %define taglevel 17
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2, pypcilib
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: PLCAPI >= 5.0
28 # the python code packaged in these are shipped on the node as well
29 Requires: pypcilib pyplnet
30
31 ### avoid having yum complain about updates, as stuff is moving around
32 # plc.d/bootmanager
33 Conflicts: myplc <= 4.3
34 # nodeconfig/boot/*
35 Conflicts: nodeconfig <= 4.3
36
37 AutoReqProv: no
38 %define debug_package %{nil}
39
40 %description
41 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
42 nodes.
43
44 %prep
45 %setup -q
46
47 %build
48 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 # Install source so that it can be rebuilt
54 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
55
56 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
57
58 # formerly in the nodeconfig module
59 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
60 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
61 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
62
63 # formerly in the MyPLC module
64 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 # initialize the boot manager upload area
71 mkdir -p /var/log/bm
72 chown apache:apache /var/log/bm
73 chmod 700 /var/log/bm
74
75 %files
76 %defattr(-,root,root,-)
77 %{_datadir}/%{name}
78 /var/www/html/boot/index.php
79 /var/www/html/boot/upload-bmlog.php
80 /var/www/html/boot/getnodeid.php
81 /etc/plc.d/bootmanager
82
83 %changelog
84 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
85 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
86
87 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
88 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
89 - fix for chosing version of parted - for f14
90 - added support for virtio deveices in /dev/vd
91 - fixed scanning of new disks
92 - slightly reviewed logs - default mode is verbose
93 - removed deprecated mkinitrd.sh
94
95 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
96 - Fix problems caused by shell redirection
97
98 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
99 - tag 5.0-13 is broken
100
101 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
102 - Add support for uploading bash_history to a central server for failboot nodes.
103 - Start to use subprocess instead of deprecated popen2 module
104 - Fix typo for VSERVERS_SIZE
105 - Add --allow-missing parameter to support different kernel configs with mkinitrd
106
107 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
108 - Revert "replace deprecated popen2 with subprocess"
109
110 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
111 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
112
113 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
114 - Fix typo
115
116 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
117 - fix typo
118
119 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
120 - disable time/count based filesystem checks
121
122 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
123 - Fix new disk additions to LVM array
124
125 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
126 - bugfix for centos5/python2.4 missing hashlib
127
128 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
129 - check sha1sum of downloaded bootstrapfs
130 - try recovering filesystem errors
131
132 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
133 - nicer initscript now uses 'action' from /etc/init.d/functions
134 - bugfix for nodes with extensions
135
136 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
137 - create /etc/planetlab if missing
138 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
139
140 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
141 - caglar's change to run MkInitrd right before kexec
142 - plus clean up old code
143
144 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
145 - first working version of 5.0:
146 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
147 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
148 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
149
150 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
151 - support for fedora 12
152
153 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
154 - - support for when the node is behind a NAT
155 - - clean up RUN_LEVEL support
156 - - support for early sshd
157
158 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
159 - Add NAT model option for nodes which don't resolve properly.
160
161 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
162 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
163 - BootServerRequest takes the 'VARS' variable to read these values.
164 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
165 - (or any other interface that accepts a POST file)
166 - build.sh bundles cacerts for boot and monitor servers (if present) to
167 - authenticate the UPLOAD_LOG_SCRIPT.
168 - Previously, these certs were re-used from the bootcd, now they are bundled
169 - with BM.  This allows the BM to point to a completely different myplc if
170 - desired, and it is still secure, because the original download is
171 - authenticated.
172
173 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
174 - raise a single exception for nodes with authentication errors
175 - fix syntax error in MakeInitrd.py
176
177 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
178 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
179 - Removed failboot and install from forced states.
180 - Removed checks for initrd in Validate
181 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
182 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
183
184 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
185 - Special handling for "forcedeth" ethernet NIC.
186
187 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
188 - include a fix for public pl dealing with old/new boot images and root
189 - environments
190
191 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
192 - review selection nodefamily at bootstrapfs install-time
193 - now based on (1) tags (2) nodefamily and (3) defaults
194 - this is required on very old bootcd
195
196 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
197 - Use modprobe module to write out /etc/modprobe.conf.
198
199 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
200 - minor updates - using the new modprobe module *not* in this tag
201
202 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
203 - load device mapper if needed, for centos5-based bootcd variant
204
205 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
206 - renumbered 4.3
207 - New step StartRunLevelAgent
208 - various other tweaks
209
210 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
211 - most of the actual network config job moved to (py)plnet
212 - support for RAWDISK
213 - network interfaces deterministically sorted
214 - does not use nodegroups anymore for getting node arch and other extensions
215 - drop yum-based extensions
216 - debug sshd started as early as possible
217 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
218 - cleaned up (drop support for bootcdv2)
219 - still needs testing
220
221 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
222 - reflects new names from the data model
223
224 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
225 - dont unload cpqphp
226
227 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
228 - changes in the state automaton logic 
229 - root+swap = 7G
230 - usb-key threshhold increased to 17 G
231 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
232
233 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
234 - renamed step InstallBootstrapRPM into InstallBootstrapFS
235 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
236 - import pypcimap rather than pypciscan
237 - initial downlaoding of plc_config made more robust
238 - root and /vservers file systems mounted ext3
239 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
240 - also seems to be using session-based authentication rather than former hmac-based one
241
242 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
243 - usage of wireless attributes fixed and tested
244 - breakpoints cleaned up (no change for production)
245 - less alarming message when floppy does not get unloaded
246
247 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
248 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
249 - removes legacy calls to PlanetLabConf.py 
250 - refrains from unloading floppy 
251 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
252
253 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
254 - Initial build.
255
256 %define module_current_branch 4.3