Tagging module BootManager - BootManager-4.3-7
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 4.3
8 %define taglevel 7
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26 Requires: tar, gnupg, sharutils, bzip2, pypcilib
27 Requires: PLCAPI >= 4.3
28
29 # the python code packaged in these are shipped on the node as well
30 Requires: pypcilib pyplnet monitor-runlevelagent
31
32 AutoReqProv: no
33 %define debug_package %{nil}
34
35 %description
36 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
37 nodes.
38
39 %prep
40 %setup -q
41
42 %build
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 # Install source so that it can be rebuilt
48 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
49
50 touch bootmanager.sh
51 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
52
53 # This is only required for 2.x bootcds.
54 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 # If run under sudo
60 if [ -n "$SUDO_USER" ] ; then
61     # Allow user to delete the build directory
62     chown -h -R $SUDO_USER .
63     # Some temporary cdroot files like /var/empty/sshd and
64     # /usr/bin/sudo get created with non-readable permissions.
65     find . -not -perm +0600 -exec chmod u+rw {} \;
66     # Allow user to delete the built RPM(s)
67     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
68 fi
69
70 %post
71 cat <<EOF
72 Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
73 PlanetLab private key.
74 EOF
75
76 %files
77 %defattr(-,root,root,-)
78 %{_datadir}/%{name}
79 %ghost /var/www/html/boot/bootmanager.sh
80 /var/www/html/boot/uudecode.gz
81
82 %changelog
83 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
84 - review selection nodefamily at bootstrapfs install-time
85 - now based on (1) tags (2) nodefamily and (3) defaults
86 - this is required on very old bootcd
87
88 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
89 - Use modprobe module to write out /etc/modprobe.conf.
90
91 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
92 - minor updates - using the new modprobe module *not* in this tag
93
94 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
95 - load device mapper if needed, for centos5-based bootcd variant
96
97 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
98 - renumbered 4.3
99 - New step StartRunLevelAgent
100 - various other tweaks
101
102 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
103 - most of the actual network config job moved to (py)plnet
104 - support for RAWDISK
105 - network interfaces deterministically sorted
106 - does not use nodegroups anymore for getting node arch and other extensions
107 - drop yum-based extensions
108 - debug sshd started as early as possible
109 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
110 - cleaned up (drop support for bootcdv2)
111 - still needs testing
112
113 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
114 - reflects new names from the data model
115
116 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
117 - dont unload cpqphp
118
119 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
120 - changes in the state automaton logic 
121 - root+swap = 7G
122 - usb-key threshhold increased to 17 G
123 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
124
125 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
126 - renamed step InstallBootstrapRPM into InstallBootstrapFS
127 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
128 - import pypcimap rather than pypciscan
129 - initial downlaoding of plc_config made more robust
130 - root and /vservers file systems mounted ext3
131 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
132 - also seems to be using session-based authentication rather than former hmac-based one
133
134 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
135 - usage of wireless attributes fixed and tested
136 - breakpoints cleaned up (no change for production)
137 - less alarming message when floppy does not get unloaded
138
139 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
140 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
141 - removes legacy calls to PlanetLabConf.py 
142 - refrains from unloading floppy 
143 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
144
145 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
146 - Initial build.
147
148 %define module_current_branch 3.2