Setting tag BootManager-5.0-2
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 5.0
8 %define taglevel 2
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25 BuildArch: noarch
26
27 Requires: tar, gnupg, sharutils, bzip2, pypcilib
28 # need the apache user at install-time
29 Requires: httpd 
30
31 Requires: PLCAPI >= 5.0
32 # the python code packaged in these are shipped on the node as well
33 Requires: pypcilib pyplnet monitor-runlevelagent
34
35 ### avoid having yum complain about updates, as stuff is moving around
36 # plc.d/bootmanager
37 Conflicts: myplc <= 4.3
38 # nodeconfig/boot/*
39 Conflicts: nodeconfig <= 4.3
40
41 AutoReqProv: no
42 %define debug_package %{nil}
43
44 %description
45 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
46 nodes.
47
48 %prep
49 %setup -q
50
51 %build
52 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 # Install source so that it can be rebuilt
58 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
59
60 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
61
62 # formerly in the nodeconfig module
63 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
64 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
65 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
66
67 # formerly in the MyPLC module
68 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 # initialize the boot manager upload area
75 mkdir -p /var/log/bm
76 chown apache:apache /var/log/bm
77 chmod 700 /var/log/bm
78
79 # NOTE: do not run this agent when installed on a myplc.
80 # xxx - a bit hacky maybe
81 chkconfig monitor-runlevelagent off
82 chkconfig --del monitor-runlevelagent
83
84 %files
85 %defattr(-,root,root,-)
86 %{_datadir}/%{name}
87 /var/www/html/boot/index.php
88 /var/www/html/boot/upload-bmlog.php
89 /var/www/html/boot/getnodeid.php
90 /etc/plc.d/bootmanager
91
92 %changelog
93 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
94 - caglar's change to run MkInitrd right before kexec
95 - plus clean up old code
96
97 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
98 - first working version of 5.0:
99 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
100 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
101 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
102
103 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
104 - support for fedora 12
105
106 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
107 - - support for when the node is behind a NAT
108 - - clean up RUN_LEVEL support
109 - - support for early sshd
110
111 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
112 - Add NAT model option for nodes which don't resolve properly.
113
114 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
115 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
116 - BootServerRequest takes the 'VARS' variable to read these values.
117 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
118 - (or any other interface that accepts a POST file)
119 - build.sh bundles cacerts for boot and monitor servers (if present) to
120 - authenticate the UPLOAD_LOG_SCRIPT.
121 - Previously, these certs were re-used from the bootcd, now they are bundled
122 - with BM.  This allows the BM to point to a completely different myplc if
123 - desired, and it is still secure, because the original download is
124 - authenticated.
125
126 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
127 - raise a single exception for nodes with authentication errors
128 - fix syntax error in MakeInitrd.py
129
130 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
131 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
132 - Removed failboot and install from forced states.
133 - Removed checks for initrd in Validate
134 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
135 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
136
137 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
138 - Special handling for "forcedeth" ethernet NIC.
139
140 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
141 - include a fix for public pl dealing with old/new boot images and root
142 - environments
143
144 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
145 - review selection nodefamily at bootstrapfs install-time
146 - now based on (1) tags (2) nodefamily and (3) defaults
147 - this is required on very old bootcd
148
149 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
150 - Use modprobe module to write out /etc/modprobe.conf.
151
152 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
153 - minor updates - using the new modprobe module *not* in this tag
154
155 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
156 - load device mapper if needed, for centos5-based bootcd variant
157
158 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
159 - renumbered 4.3
160 - New step StartRunLevelAgent
161 - various other tweaks
162
163 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
164 - most of the actual network config job moved to (py)plnet
165 - support for RAWDISK
166 - network interfaces deterministically sorted
167 - does not use nodegroups anymore for getting node arch and other extensions
168 - drop yum-based extensions
169 - debug sshd started as early as possible
170 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
171 - cleaned up (drop support for bootcdv2)
172 - still needs testing
173
174 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
175 - reflects new names from the data model
176
177 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
178 - dont unload cpqphp
179
180 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
181 - changes in the state automaton logic 
182 - root+swap = 7G
183 - usb-key threshhold increased to 17 G
184 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
185
186 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
187 - renamed step InstallBootstrapRPM into InstallBootstrapFS
188 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
189 - import pypcimap rather than pypciscan
190 - initial downlaoding of plc_config made more robust
191 - root and /vservers file systems mounted ext3
192 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
193 - also seems to be using session-based authentication rather than former hmac-based one
194
195 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
196 - usage of wireless attributes fixed and tested
197 - breakpoints cleaned up (no change for production)
198 - less alarming message when floppy does not get unloaded
199
200 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
201 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
202 - removes legacy calls to PlanetLabConf.py 
203 - refrains from unloading floppy 
204 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
205
206 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
207 - Initial build.
208
209 %define module_current_branch 4.3