remove svn keywords and use %{SCMURL} in spec file
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.0
4 %define taglevel 15
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2, pypcilib
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: PLCAPI >= 5.0
28 # the python code packaged in these are shipped on the node as well
29 Requires: pypcilib pyplnet monitor-runlevelagent
30
31 ### avoid having yum complain about updates, as stuff is moving around
32 # plc.d/bootmanager
33 Conflicts: myplc <= 4.3
34 # nodeconfig/boot/*
35 Conflicts: nodeconfig <= 4.3
36
37 AutoReqProv: no
38 %define debug_package %{nil}
39
40 %description
41 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
42 nodes.
43
44 %prep
45 %setup -q
46
47 %build
48 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 # Install source so that it can be rebuilt
54 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
55
56 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
57
58 # formerly in the nodeconfig module
59 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
60 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
61 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
62
63 # formerly in the MyPLC module
64 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 # initialize the boot manager upload area
71 mkdir -p /var/log/bm
72 chown apache:apache /var/log/bm
73 chmod 700 /var/log/bm
74
75 # NOTE: do not run this agent when installed on a myplc.
76 # xxx - a bit hacky maybe
77 chkconfig monitor-runlevelagent off
78 chkconfig --del monitor-runlevelagent
79
80 %files
81 %defattr(-,root,root,-)
82 %{_datadir}/%{name}
83 /var/www/html/boot/index.php
84 /var/www/html/boot/upload-bmlog.php
85 /var/www/html/boot/getnodeid.php
86 /etc/plc.d/bootmanager
87
88 %changelog
89 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
90 - Fix problems caused by shell redirection
91
92 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
93 - tag 5.0-13 is broken
94
95 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
96 - Add support for uploading bash_history to a central server for failboot nodes.
97 - Start to use subprocess instead of deprecated popen2 module
98 - Fix typo for VSERVERS_SIZE
99 - Add --allow-missing parameter to support different kernel configs with mkinitrd
100
101 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
102 - Revert "replace deprecated popen2 with subprocess"
103
104 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
105 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
106
107 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
108 - Fix typo
109
110 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
111 - fix typo
112
113 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
114 - disable time/count based filesystem checks
115
116 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
117 - Fix new disk additions to LVM array
118
119 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
120 - bugfix for centos5/python2.4 missing hashlib
121
122 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
123 - check sha1sum of downloaded bootstrapfs
124 - try recovering filesystem errors
125
126 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
127 - nicer initscript now uses 'action' from /etc/init.d/functions
128 - bugfix for nodes with extensions
129
130 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
131 - create /etc/planetlab if missing
132 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
133
134 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
135 - caglar's change to run MkInitrd right before kexec
136 - plus clean up old code
137
138 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
139 - first working version of 5.0:
140 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
141 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
142 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
143
144 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
145 - support for fedora 12
146
147 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
148 - - support for when the node is behind a NAT
149 - - clean up RUN_LEVEL support
150 - - support for early sshd
151
152 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
153 - Add NAT model option for nodes which don't resolve properly.
154
155 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
156 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
157 - BootServerRequest takes the 'VARS' variable to read these values.
158 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
159 - (or any other interface that accepts a POST file)
160 - build.sh bundles cacerts for boot and monitor servers (if present) to
161 - authenticate the UPLOAD_LOG_SCRIPT.
162 - Previously, these certs were re-used from the bootcd, now they are bundled
163 - with BM.  This allows the BM to point to a completely different myplc if
164 - desired, and it is still secure, because the original download is
165 - authenticated.
166
167 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
168 - raise a single exception for nodes with authentication errors
169 - fix syntax error in MakeInitrd.py
170
171 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
172 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
173 - Removed failboot and install from forced states.
174 - Removed checks for initrd in Validate
175 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
176 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
177
178 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
179 - Special handling for "forcedeth" ethernet NIC.
180
181 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
182 - include a fix for public pl dealing with old/new boot images and root
183 - environments
184
185 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
186 - review selection nodefamily at bootstrapfs install-time
187 - now based on (1) tags (2) nodefamily and (3) defaults
188 - this is required on very old bootcd
189
190 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
191 - Use modprobe module to write out /etc/modprobe.conf.
192
193 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
194 - minor updates - using the new modprobe module *not* in this tag
195
196 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
197 - load device mapper if needed, for centos5-based bootcd variant
198
199 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
200 - renumbered 4.3
201 - New step StartRunLevelAgent
202 - various other tweaks
203
204 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
205 - most of the actual network config job moved to (py)plnet
206 - support for RAWDISK
207 - network interfaces deterministically sorted
208 - does not use nodegroups anymore for getting node arch and other extensions
209 - drop yum-based extensions
210 - debug sshd started as early as possible
211 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
212 - cleaned up (drop support for bootcdv2)
213 - still needs testing
214
215 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
216 - reflects new names from the data model
217
218 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
219 - dont unload cpqphp
220
221 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
222 - changes in the state automaton logic 
223 - root+swap = 7G
224 - usb-key threshhold increased to 17 G
225 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
226
227 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
228 - renamed step InstallBootstrapRPM into InstallBootstrapFS
229 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
230 - import pypcimap rather than pypciscan
231 - initial downlaoding of plc_config made more robust
232 - root and /vservers file systems mounted ext3
233 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
234 - also seems to be using session-based authentication rather than former hmac-based one
235
236 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
237 - usage of wireless attributes fixed and tested
238 - breakpoints cleaned up (no change for production)
239 - less alarming message when floppy does not get unloaded
240
241 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
242 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
243 - removes legacy calls to PlanetLabConf.py 
244 - refrains from unloading floppy 
245 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
246
247 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
248 - Initial build.
249
250 %define module_current_branch 4.3