Tagging module BootManager - BootManager-3.2-5
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 3.2
8 %define taglevel 5
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26 Requires: tar, gnupg, sharutils, bzip2, pypcilib
27
28 AutoReqProv: no
29 %define debug_package %{nil}
30
31 %description
32 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
33 nodes.
34
35 %prep
36 %setup -q
37
38 %build
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 # Install source so that it can be rebuilt
44 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
45
46 touch bootmanager.sh
47 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
48
49 # This is only required for 2.x bootcds.
50 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 # If run under sudo
56 if [ -n "$SUDO_USER" ] ; then
57     # Allow user to delete the build directory
58     chown -h -R $SUDO_USER .
59     # Some temporary cdroot files like /var/empty/sshd and
60     # /usr/bin/sudo get created with non-readable permissions.
61     find . -not -perm +0600 -exec chmod u+rw {} \;
62     # Allow user to delete the built RPM(s)
63     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
64 fi
65
66 %post
67 cat <<EOF
68 Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
69 PlanetLab private key.
70 EOF
71
72 %files
73 %defattr(-,root,root,-)
74 %{_datadir}/%{name}
75 %ghost /var/www/html/boot/bootmanager.sh
76 /var/www/html/boot/uudecode.gz
77
78 %changelog
79 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
80 - renamed step InstallBootstrapRPM into InstallBootstrapFS
81 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
82 - import pypcimap rather than pypciscan
83 - initial downlaoding of plc_config made more robust
84 - root and /vservers file systems mounted ext3
85 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
86 - also seems to be using session-based authentication rather than former hmac-based one
87
88 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
89 - usage of wireless attributes fixed and tested
90 - breakpoints cleaned up (no change for production)
91 - less alarming message when floppy does not get unloaded
92
93 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
94 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
95 - removes legacy calls to PlanetLabConf.py 
96 - refrains from unloading floppy 
97 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
98
99 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
100 - Initial build.