Tagging module BootManager - BootManager-5.0-2
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 5.0
8 %define taglevel 2
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26 Requires: tar, gnupg, sharutils, bzip2, pypcilib
27 Requires: PLCAPI >= 5.0
28
29 AutoReqProv: no
30 %define debug_package %{nil}
31
32 %description
33 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
34 nodes.
35
36 %prep
37 %setup -q
38
39 %build
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 # Install source so that it can be rebuilt
45 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
46
47 touch bootmanager.sh
48 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
49
50 # This is only required for 2.x bootcds.
51 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 # If run under sudo
57 if [ -n "$SUDO_USER" ] ; then
58     # Allow user to delete the build directory
59     chown -h -R $SUDO_USER .
60     # Some temporary cdroot files like /var/empty/sshd and
61     # /usr/bin/sudo get created with non-readable permissions.
62     find . -not -perm +0600 -exec chmod u+rw {} \;
63     # Allow user to delete the built RPM(s)
64     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
65 fi
66
67 %post
68 cat <<EOF
69 Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
70 PlanetLab private key.
71 EOF
72
73 %files
74 %defattr(-,root,root,-)
75 %{_datadir}/%{name}
76 %ghost /var/www/html/boot/bootmanager.sh
77 /var/www/html/boot/uudecode.gz
78
79 %changelog
80 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
81 - most of the actual network config job moved to (py)plnet
82 - support for RAWDISK
83 - network interfaces deterministically sorted
84 - does not use nodegroups anymore for getting node arch and other extensions
85 - drop yum-based extensions
86 - debug sshd started as early as possible
87 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
88 - cleaned up (drop support for bootcdv2)
89 - still needs testing
90
91 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
92 - reflects new names from the data model
93
94 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
95 - dont unload cpqphp
96
97 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
98 - changes in the state automaton logic 
99 - root+swap = 7G
100 - usb-key threshhold increased to 17 G
101 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
102
103 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
104 - renamed step InstallBootstrapRPM into InstallBootstrapFS
105 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
106 - import pypcimap rather than pypciscan
107 - initial downlaoding of plc_config made more robust
108 - root and /vservers file systems mounted ext3
109 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
110 - also seems to be using session-based authentication rather than former hmac-based one
111
112 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
113 - usage of wireless attributes fixed and tested
114 - breakpoints cleaned up (no change for production)
115 - less alarming message when floppy does not get unloaded
116
117 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
118 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
119 - removes legacy calls to PlanetLabConf.py 
120 - refrains from unloading floppy 
121 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
122
123 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
124 - Initial build.
125
126 %define module_current_branch 3.2