first draft of a deployment-friendly bootmanager
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{_arch}
7
8 %define name bootmanager-%{nodefamily}
9 %define version 4.3
10 %define taglevel 16
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Vendor: PlanetLab
15 Packager: PlanetLab Central <support@planet-lab.org>
16 Distribution: PlanetLab %{plrelease}
17 URL: %(echo %{url} | cut -d ' ' -f 2)
18
19 Summary: The PlanetLab Boot Manager
20 Name: %{name}
21 Version: %{version}
22 Release: %{release}
23 License: BSD
24 Group: System Environment/Base
25 Source0: %{name}-%{version}.tar.gz
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
27 BuildArch: noarch
28
29 Requires: tar, gnupg, sharutils, bzip2, pypcilib
30 Requires: PLCAPI >= 4.3
31 # the python code packaged in these are shipped on the node as well
32 Requires: pypcilib pyplnet monitor-runlevelagent
33
34 # plc.d/bootmanager is moving
35 Conflicts: myplc <= 4.3.37
36 # nodeconfig/boot/index.php is moving
37 Conflicts: nodeconfig <= 4.3.7
38
39 AutoReqProv: no
40 %define debug_package %{nil}
41
42 %description
43 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
44 nodes.
45
46 %prep
47 %setup -q
48
49 %build
50 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 # Install source so that it can be rebuilt
56 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
57
58 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
59
60 # formerly in the nodeconfig module
61 install -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
62
63 # formerly in the MyPLC module
64 install -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/pld.c/bootmanager
65
66 #touch bootmanager.sh
67 #install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
68
69 # This is only required for 2.x bootcds.
70 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 # signing of botmanager.sh occurs as part of plc.d/bootmanager
77
78 # NOTE: do not run this agent when installed on a myplc.
79 # xxx - a bit hacky maybe
80 chkconfig monitor-runlevelagent off
81 chkconfig --del monitor-runlevelagent
82
83 %files
84 %defattr(-,root,root,-)
85 %{_datadir}/%{name}
86 /var/www/html/boot/index.php
87 /etc/pld.c/bootmanager
88 /var/www/html/boot/uudecode.gz
89 #%ghost /var/www/html/boot/bootmanager.sh
90
91 %changelog
92 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
93 - support for fedora 12
94
95 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
96 - - support for when the node is behind a NAT
97 - - clean up RUN_LEVEL support
98 - - support for early sshd
99
100 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
101 - Add NAT model option for nodes which don't resolve properly.
102
103 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
104 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
105 - BootServerRequest takes the 'VARS' variable to read these values.
106 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
107 - (or any other interface that accepts a POST file)
108 - build.sh bundles cacerts for boot and monitor servers (if present) to
109 - authenticate the UPLOAD_LOG_SCRIPT.
110 - Previously, these certs were re-used from the bootcd, now they are bundled
111 - with BM.  This allows the BM to point to a completely different myplc if
112 - desired, and it is still secure, because the original download is
113 - authenticated.
114
115 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
116 - raise a single exception for nodes with authentication errors
117 - fix syntax error in MakeInitrd.py
118
119 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
120 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
121 - Removed failboot and install from forced states.
122 - Removed checks for initrd in Validate
123 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
124 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
125
126 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
127 - Special handling for "forcedeth" ethernet NIC.
128
129 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
130 - include a fix for public pl dealing with old/new boot images and root
131 - environments
132
133 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
134 - review selection nodefamily at bootstrapfs install-time
135 - now based on (1) tags (2) nodefamily and (3) defaults
136 - this is required on very old bootcd
137
138 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
139 - Use modprobe module to write out /etc/modprobe.conf.
140
141 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
142 - minor updates - using the new modprobe module *not* in this tag
143
144 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
145 - load device mapper if needed, for centos5-based bootcd variant
146
147 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
148 - renumbered 4.3
149 - New step StartRunLevelAgent
150 - various other tweaks
151
152 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
153 - most of the actual network config job moved to (py)plnet
154 - support for RAWDISK
155 - network interfaces deterministically sorted
156 - does not use nodegroups anymore for getting node arch and other extensions
157 - drop yum-based extensions
158 - debug sshd started as early as possible
159 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
160 - cleaned up (drop support for bootcdv2)
161 - still needs testing
162
163 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
164 - reflects new names from the data model
165
166 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
167 - dont unload cpqphp
168
169 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
170 - changes in the state automaton logic 
171 - root+swap = 7G
172 - usb-key threshhold increased to 17 G
173 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
174
175 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
176 - renamed step InstallBootstrapRPM into InstallBootstrapFS
177 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
178 - import pypcimap rather than pypciscan
179 - initial downlaoding of plc_config made more robust
180 - root and /vservers file systems mounted ext3
181 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
182 - also seems to be using session-based authentication rather than former hmac-based one
183
184 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
185 - usage of wireless attributes fixed and tested
186 - breakpoints cleaned up (no change for production)
187 - less alarming message when floppy does not get unloaded
188
189 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
190 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
191 - removes legacy calls to PlanetLabConf.py 
192 - refrains from unloading floppy 
193 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
194
195 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
196 - Initial build.
197
198 %define module_current_branch 3.2