Setting tag BootstrapFS-2.0-1
[bootstrapfs.git] / bootstrapfs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define extensionfamily %{distroname}-%{_arch}
8
9 %define name bootstrapfs-%{nodefamily}
10 %define version 2.0
11 %define taglevel 1
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: The PlanetLab Bootstrap Filesystems for %{nodefamily}
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Base
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30 # other archs must be able to install this
31 BuildArch: noarch
32
33 Requires: tar, gnupg, sharutils, bzip2
34
35 # 5.0 now has 3-fold nodefamily
36 %define obsolete_nodefamily %{pldistro}-%{_arch}
37 Obsoletes: bootstrapfs-%{obsolete_nodefamily}
38
39 AutoReqProv: no
40 %define debug_package %{nil}
41
42 %description
43
44 The PlanetLab Bootstrap Filesystem(s) are downloaded by the
45 BootManager to instantiate a node with a new filesystem.
46
47 %package plain
48 Summary: The (uncompressed) PlanetLab Bootstrap Filesystems for %{nodefamily}
49 Group: System Environment/Base
50 %description plain
51 This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
52
53 %package -n nodeyum
54 Summary: the MyPLC-side utilities for tweaking nodes yum configs
55 Group: System Environment/Base
56 %description -n nodeyum 
57 Utility scripts for configuring node updates. This package is designed
58 for the MyPLC side.
59
60 %prep
61 %setup -q
62
63 %build
64 pushd BootstrapFS
65 ./build.sh %{pldistro} 
66 popd
67
68 # xxx in a multi-flavour myplc, we should ship for all fcdistros
69 # and let the php scripts do the right thing
70
71 pushd BootstrapFS/nodeconfig/yum
72 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
73 for fcdistro in $(ls); do
74     [ -d $fcdistro ] || continue
75     # get kexcludes for that distro
76     KEXCLUDE="exclude=$(../../../build/getkexcludes.sh -f $fcdistro)"
77     pushd $fcdistro/yum.myplc.d
78     echo "* Handling KEXCLUDE in yum repo for $fcdistro ($KEXCLUDE)"
79     for filein in $(find . -name '*.in') ; do
80         file=$(echo $filein | sed -e "s,\.in$,,")
81         sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
82     done
83     rm -f stock.repo
84     cat *.repo > stock.repo
85     popd
86 done
87 popd
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 pushd BootstrapFS
93 #arch=$(uname -i)
94
95 install -D -m 644 bootstrapfs-%{nodefamily}.tar.bz2 \
96         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.bz2
97 install -D -m 644 bootstrapfs-%{nodefamily}.tar \
98         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar
99
100 for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
101     NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
102     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 \
103                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 
104     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar \
105                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar 
106 done
107 popd
108
109 pushd BootstrapFS
110 echo "* Installing MyPLC-side nodes yum config utilities"
111 # expose (fixed) myplc.repo.php as                                          https://<plc>/yum/myplc.repo.php
112 install -D -m 644 ./nodeconfig/yum/myplc.repo.php                           $RPM_BUILD_ROOT/var/www/html/yum/myplc.repo.php
113 # expose the fcdistro-dependant yum.conf as                                 https://<plc>/yum/yum.conf
114 install -D -m 644 ./nodeconfig/yum/%{distroname}/yum.conf                   $RPM_BUILD_ROOT/var/www/html/yum/yum.conf
115 # expose the (fcdistro-dependant) stock.repo as                             https://<plc>/yum/stock.repo
116 install -D -m 644 ./nodeconfig/yum/%{distroname}/yum.myplc.d/stock.repo     $RPM_BUILD_ROOT/var/www/html/yum/stock.repo
117
118 # Install initscripts
119 echo "* Installing plc.d initscripts"
120 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
121 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
122
123 popd
124
125 pushd BootstrapFS
126 echo "* Installing db-config.d files"
127 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
128 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
129 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
130 popd
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135
136 %files
137 %defattr(-,root,root,-)
138 /var/www/html/boot/bootstrapfs*.tar.bz2
139
140 %files plain
141 %defattr(-,root,root,-)
142 /var/www/html/boot/bootstrapfs*.tar
143
144 %files -n nodeyum
145 %defattr(-,root,root,-)
146 /var/www/html/yum
147 /etc/planetlab/db-config.d
148 /etc/plc.d
149
150 %changelog
151 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
152 - first working version of 5.0:
153 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
154 - nodefailiy is 3-fold with pldistro-fcdistro-arch
155 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
156
157 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
158 - for building on fedora12
159
160 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
161 - cosmetic change in message at build-time
162
163 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
164 - can use groups in the pkgs file with +++ for space
165
166 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
167 - bugfix for when a .post script is not needed
168
169 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
170 - search post-install scripts (.post) in path (distro, then planetlab)
171 - mostly useful for externally-defined pldistros
172
173 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
174 - fix build bug when dealing with extensions
175
176 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
177 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
178
179 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
180 - cosmetic changes in build: displays duration, and shows up in summary
181
182 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
183 - Do not overwrite yumgroups.xml upon updates of noderepo
184
185 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
186 - uses the right yum.conf when building images
187
188 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
189 - rpm release tag does not need pldistro as it is already part of the rpm name
190
191 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
192 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
193 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
194
195 * Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
196 - search more carefully for alternate pkgs files
197 - handling of sysconfig/crontab and creation of site_admin reviewed
198 - (this tag is set with module-tag.py)
199
200 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
201 - Initial build.
202
203 %define module_current_branch 1.0