multi-fcdistro yum config
[bootstrapfs.git] / bootstrapfs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define extensionfamily %{distroname}-%{_arch}
8
9 %define name bootstrapfs-%{nodefamily}
10 %define version 2.0
11 %define taglevel 2
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: The PlanetLab Bootstrap Filesystems for %{nodefamily}
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Base
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30 # other archs must be able to install this
31 BuildArch: noarch
32
33 Requires: tar, gnupg, sharutils, bzip2
34
35 # 5.0 now has 3-fold nodefamily
36 %define obsolete_nodefamily %{pldistro}-%{_arch}
37 Obsoletes: bootstrapfs-%{obsolete_nodefamily}
38
39 AutoReqProv: no
40 %define debug_package %{nil}
41
42 %description
43
44 The PlanetLab Bootstrap Filesystem(s) are downloaded by the
45 BootManager to instantiate a node with a new filesystem.
46
47 %package plain
48 Summary: The (uncompressed) PlanetLab Bootstrap Filesystems for %{nodefamily}
49 Group: System Environment/Base
50 %description plain
51 This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
52
53 %package -n nodeyum
54 Summary: the MyPLC-side utilities for tweaking nodes yum configs
55 Group: System Environment/Base
56 %description -n nodeyum 
57 Utility scripts for configuring node updates. This package is designed
58 for the MyPLC side.
59
60 %prep
61 %setup -q
62
63 %build
64
65 ############################## node-side
66 pushd BootstrapFS
67 ./build.sh %{pldistro} 
68 popd
69
70 ############################## server-side
71 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
72 pushd BootstrapFS/nodeconfig/yum
73 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
74 for fcdistro in $(ls); do
75     [ -d $fcdistro ] || continue
76     # get kexcludes for that distro
77     KEXCLUDE="exclude=$(../../../build/getkexcludes.sh -f $fcdistro)"
78     pushd $fcdistro/yum.myplc.d
79     echo "* Handling KEXCLUDE in yum repo for $fcdistro ($KEXCLUDE)"
80     for filein in $(find . -name '*.in') ; do
81         file=$(echo $filein | sed -e "s,\.in$,,")
82         sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
83     done
84     rm -f stock.repo
85     cat *.repo > stock.repo
86     popd
87 done
88 popd
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 ############################## node-side
94 pushd BootstrapFS
95
96 install -D -m 644 bootstrapfs-%{nodefamily}.tar.bz2 \
97         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.bz2
98 install -D -m 644 bootstrapfs-%{nodefamily}.tar \
99         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar
100
101 for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
102     NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
103     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 \
104                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 
105     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar \
106                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar 
107 done
108 popd
109
110 ############################## server-side
111 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
112 pushd BootstrapFS
113 echo "* Installing MyPLC-side nodes yum config utilities (support for multi-fcdistro)"
114 mkdir -p $RPM_BUILD_ROOT/var/www/html/yum/
115 rsync -av ./nodeconfig/yum/     $RPM_BUILD_ROOT/var/www/html/yum/
116
117 # Install initscripts
118 echo "* Installing plc.d initscripts"
119 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
120 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
121
122 echo "* Installing db-config.d files"
123 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
124 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
125 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
126 popd
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131
132 %files
133 %defattr(-,root,root,-)
134 /var/www/html/boot/bootstrapfs*.tar.bz2
135
136 %files plain
137 %defattr(-,root,root,-)
138 /var/www/html/boot/bootstrapfs*.tar
139
140 %files -n nodeyum
141 %defattr(-,root,root,-)
142 /var/www/html/yum
143 /etc/planetlab/db-config.d
144 /etc/plc.d
145
146 %changelog
147 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
148 - new slicerepo package for exposing stuff to slivers
149
150 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
151 - first working version of 5.0:
152 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
153 - nodefailiy is 3-fold with pldistro-fcdistro-arch
154 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
155
156 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
157 - for building on fedora12
158
159 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
160 - cosmetic change in message at build-time
161
162 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
163 - can use groups in the pkgs file with +++ for space
164
165 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
166 - bugfix for when a .post script is not needed
167
168 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
169 - search post-install scripts (.post) in path (distro, then planetlab)
170 - mostly useful for externally-defined pldistros
171
172 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
173 - fix build bug when dealing with extensions
174
175 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
176 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
177
178 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
179 - cosmetic changes in build: displays duration, and shows up in summary
180
181 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
182 - Do not overwrite yumgroups.xml upon updates of noderepo
183
184 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
185 - uses the right yum.conf when building images
186
187 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
188 - rpm release tag does not need pldistro as it is already part of the rpm name
189
190 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
191 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
192 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
193
194 * Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
195 - search more carefully for alternate pkgs files
196 - handling of sysconfig/crontab and creation of site_admin reviewed
197 - (this tag is set with module-tag.py)
198
199 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
200 - Initial build.
201
202 %define module_current_branch 1.0