prepare for lowercaing module name
[bootstrapfs.git] / bootstrapfs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define extensionfamily %{distroname}-%{_arch}
8
9 %define name bootstrapfs-%{nodefamily}
10 %define version 2.0
11 %define taglevel 5
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: The PlanetLab Bootstrap Filesystems for %{nodefamily}
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Base
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30 # other archs must be able to install this
31 BuildArch: noarch
32
33 Requires: tar, gnupg, sharutils, bzip2
34
35 # 5.0 now has 3-fold nodefamily
36 %define obsolete_nodefamily %{pldistro}-%{_arch}
37 Obsoletes: bootstrapfs-%{obsolete_nodefamily}
38
39 AutoReqProv: no
40 %define debug_package %{nil}
41
42 %description
43
44 The PlanetLab Bootstrap Filesystem(s) are downloaded by the
45 BootManager to instantiate a node with a new filesystem.
46
47 %package plain
48 Summary: The (uncompressed) PlanetLab Bootstrap Filesystems for %{nodefamily}
49 Group: System Environment/Base
50 %description plain
51 This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
52
53 %package -n nodeyum
54 Summary: the MyPLC-side utilities for tweaking nodes yum configs
55 Group: System Environment/Base
56 %description -n nodeyum 
57 Utility scripts for configuring node updates. This package is designed
58 for the MyPLC side.
59
60 %prep
61 %setup -q
62
63 %build
64
65 ############################## node-side
66 [ -d bootstrapfs ] || ln -s BootstrapFS bootstrapfs
67 pushd bootstrapfs
68 ./build.sh %{pldistro} 
69 popd
70
71 ############################## server-side
72 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
73 pushd bootstrapfs/nodeconfig/yum
74 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
75 for fcdistro in $(ls); do
76     [ -d $fcdistro ] || continue
77     # get kexcludes for that distro
78     KEXCLUDE="exclude=$(../../../build/getkexcludes.sh -f $fcdistro)"
79     pushd $fcdistro/yum.myplc.d
80     echo "* Handling KEXCLUDE in yum repo for $fcdistro ($KEXCLUDE)"
81     for filein in $(find . -name '*.in') ; do
82         file=$(echo $filein | sed -e "s,\.in$,,")
83         sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
84     done
85     rm -f stock.repo
86     cat *.repo > stock.repo
87     popd
88 done
89 popd
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 ############################## node-side
95 pushd bootstrapfs
96
97 install -D -m 644 bootstrapfs-%{nodefamily}.tar.bz2 \
98         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.bz2
99 sha1sum $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.bz2 > \
100         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.bz2.sha1sum
101
102 install -D -m 644 bootstrapfs-%{nodefamily}.tar \
103         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar
104 sha1sum $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar > \
105         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.sha1sum
106
107 for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
108     NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
109     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 \
110                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 
111     sha1sum $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{nodefamily}.tar.bz2 > \
112         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{nodefamily}.tar.bz2.sha1sum
113
114     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar \
115                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar
116     sha1sum $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar > \
117         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar.sha1sum
118 done
119 popd
120
121 ############################## server-side
122 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
123 pushd bootstrapfs
124 echo "* Installing MyPLC-side nodes yum config utilities (support for multi-fcdistro)"
125 mkdir -p $RPM_BUILD_ROOT/var/www/html/yum/
126 rsync -av ./nodeconfig/yum/     $RPM_BUILD_ROOT/var/www/html/yum/
127
128 # Install initscripts
129 echo "* Installing plc.d initscripts"
130 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
131 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
132
133 echo "* Installing db-config.d files"
134 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
135 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
136 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
137 popd
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142
143 %files
144 %defattr(-,root,root,-)
145 /var/www/html/boot/bootstrapfs*.tar.bz2
146 /var/www/html/boot/bootstrapfs*.tar.bz2.sha1sum
147
148 %files plain
149 %defattr(-,root,root,-)
150 /var/www/html/boot/bootstrapfs*.tar
151 /var/www/html/boot/bootstrapfs*.tar.sha1sum
152
153 %files -n nodeyum
154 %defattr(-,root,root,-)
155 /var/www/html/yum
156 /etc/planetlab/db-config.d
157 /etc/plc.d
158
159 %changelog
160 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
161 - support different flavours of vservers on nodes
162
163 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
164 - fix unmatched $ in URL svn keywords
165
166 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
167 - choice between various pldistros is not made at build time, but at run time
168 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
169 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
170 - the https method does not work on fedora 12, and GPG is used below anyway
171
172 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
173 - new slicerepo package for exposing stuff to slivers
174
175 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
176 - first working version of 5.0:
177 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
178 - nodefailiy is 3-fold with pldistro-fcdistro-arch
179 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
180
181 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
182 - for building on fedora12
183
184 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
185 - cosmetic change in message at build-time
186
187 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
188 - can use groups in the pkgs file with +++ for space
189
190 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
191 - bugfix for when a .post script is not needed
192
193 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
194 - search post-install scripts (.post) in path (distro, then planetlab)
195 - mostly useful for externally-defined pldistros
196
197 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
198 - fix build bug when dealing with extensions
199
200 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
201 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
202
203 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
204 - cosmetic changes in build: displays duration, and shows up in summary
205
206 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
207 - Do not overwrite yumgroups.xml upon updates of noderepo
208
209 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
210 - uses the right yum.conf when building images
211
212 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
213 - rpm release tag does not need pldistro as it is already part of the rpm name
214
215 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
216 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
217 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
218
219 * Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
220 - search more carefully for alternate pkgs files
221 - handling of sysconfig/crontab and creation of site_admin reviewed
222 - (this tag is set with module-tag.py)
223
224 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
225 - Initial build.
226
227 %define module_current_branch 1.0