conf_files belong to the same module
[bootstrapfs.git] / bootstrapfs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define extensionfamily %{distroname}-%{_arch}
8
9 %define name bootstrapfs-%{nodefamily}
10 %define version 2.0
11 %define taglevel 0
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: The PlanetLab Bootstrap Filesystems for %{nodefamily}
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Base
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30 # other archs must be able to install this
31 BuildArch: noarch
32
33 Requires: tar, gnupg, sharutils, bzip2
34
35 # 5.0 now has 3-fold nodefamily
36 %define obsolete_nodefamily %{pldistro}-%{_arch}
37 Obsoletes: bootstrapfs-%{obsolete_nodefamily}
38
39 AutoReqProv: no
40 %define debug_package %{nil}
41
42 %description
43
44 The PlanetLab Bootstrap Filesystem(s) are downloaded by the
45 BootManager to instantiate a node with a new filesystem.
46
47 %package plain
48 Summary: The (uncompressed) PlanetLab Bootstrap Filesystems for %{nodefamily}
49 Group: System Environment/Base
50 %description plain
51 This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
52
53 %package -n nodeyum
54 Summary: the MyPLC-side utilities for tweaking nodes yum configs
55 Group: System Environment/Base
56 %description -n nodeyum 
57 Utility scripts for configuring node updates. This package is designed
58 for the MyPLC side.
59 # need the apache user at install-time
60 Requires: httpd 
61
62 %prep
63 %setup -q
64
65 %build
66 pushd BootstrapFS
67 ./build.sh %{pldistro} 
68 popd
69
70 # xxx in a multi-flavour myplc, we should ship for all fcdistros
71 # and let the php scripts do the right thing
72
73 pushd BootstrapFS/nodeconfig/yum
74 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
75 for fcdistro in $(ls); do
76     [ -d $fcdistro ] || continue
77     # get kexcludes for that distro
78     KEXCLUDE="exclude=$(../../../build/getkexcludes.sh -f $fcdistro)"
79     pushd $fcdistro/yum.myplc.d
80     echo "* Handling KEXCLUDE in yum repo for $fcdistro ($KEXCLUDE)"
81     for filein in $(find . -name '*.in') ; do
82         file=$(echo $filein | sed -e "s,\.in$,,")
83         sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
84     done
85     rm -f stock.repo
86     cat *.repo > stock.repo
87     popd
88 done
89 popd
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 pushd BootstrapFS
95 #arch=$(uname -i)
96
97 install -D -m 644 bootstrapfs-%{nodefamily}.tar.bz2 \
98         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.bz2
99 install -D -m 644 bootstrapfs-%{nodefamily}.tar \
100         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar
101
102 for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
103     NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
104     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 \
105                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 
106     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar \
107                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar 
108 done
109 popd
110
111 pushd BootstrapFS/nodeconfig/yum
112 echo "* Installing MyPLC-side yum stuff"
113 # expose (fixed) myplc.repo.php as                                          https://<plc>/yum/myplc.repo.php
114 install -D -m 644 ./yum/myplc.repo.php                       $RPM_BUILD_ROOT/var/www/html/yum/myplc.repo.php
115 # expose the fcdistro-dependant yum.conf as                                 https://<plc>/yum/yum.conf
116 install -D -m 644 ./yum/%{distroname}/yum.conf               $RPM_BUILD_ROOT/var/www/html/yum/yum.conf
117 # expose the (fcdistro-dependant) stock.repo as                             https://<plc>/yum/stock.repo
118 install -D -m 644 ./yum/%{distroname}/yum.myplc.d/stock.repo $RPM_BUILD_ROOT/var/www/html/yum/stock.repo
119 popd
120
121 pushd BootstrapFS
122 echo "* Installing db-config.d files"
123 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
124 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
125 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
126 popd
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post -n nodeyum
132 # the boot manager upload area
133 mkdir -p /var/log/bm
134 chown apache:apache /var/log/bm
135 chmod 700 /var/log/bm
136
137
138 %files
139 %defattr(-,root,root,-)
140 /var/www/html/boot/bootstrapfs*.tar.bz2
141
142 %files plain
143 %defattr(-,root,root,-)
144 /var/www/html/boot/bootstrapfs*.tar
145
146 %files -n nodeyum
147 %defattr(-,root,root,-)
148 /var/www/html/yum
149 /etc/planetlab/db-config.d
150
151 %changelog
152 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
153 - for building on fedora12
154
155 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
156 - cosmetic change in message at build-time
157
158 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
159 - can use groups in the pkgs file with +++ for space
160
161 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
162 - bugfix for when a .post script is not needed
163
164 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
165 - search post-install scripts (.post) in path (distro, then planetlab)
166 - mostly useful for externally-defined pldistros
167
168 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
169 - fix build bug when dealing with extensions
170
171 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
172 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
173
174 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
175 - cosmetic changes in build: displays duration, and shows up in summary
176
177 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
178 - Do not overwrite yumgroups.xml upon updates of noderepo
179
180 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
181 - uses the right yum.conf when building images
182
183 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
184 - rpm release tag does not need pldistro as it is already part of the rpm name
185
186 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
187 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
188 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
189
190 * Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
191 - search more carefully for alternate pkgs files
192 - handling of sysconfig/crontab and creation of site_admin reviewed
193 - (this tag is set with module-tag.py)
194
195 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
196 - Initial build.
197
198 %define module_current_branch 1.0