fb9515ad2c9d9860c3db4abdf939fb28131d1d01
[bootstrapfs.git] / bootstrapfs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define extensionfamily %{distroname}-%{_arch}
8
9 %define name bootstrapfs-%{nodefamily}
10 %define version 2.0
11 %define taglevel 0
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: The PlanetLab Bootstrap Filesystems for %{nodefamily}
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Base
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30 # other archs must be able to install this
31 BuildArch: noarch
32
33 Requires: tar, gnupg, sharutils, bzip2
34
35 AutoReqProv: no
36 %define debug_package %{nil}
37
38 %description
39
40 The PlanetLab Bootstrap Filesystem(s) are downloaded by the
41 BootManager to instantiate a node with a new filesystem.
42
43 %package plain
44 Summary: The (uncompressed) PlanetLab Bootstrap Filesystems for %{nodefamily}
45 Group: System Environment/Base
46 %description plain
47 This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
48
49 %prep
50 %setup -q
51
52 %build
53 pushd BootstrapFS
54 ./build.sh %{pldistro} 
55 popd BootstrapFS
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 pushd BootstrapFS
61 #arch=$(uname -i)
62
63 install -D -m 644 bootstrapfs-%{nodefamily}.tar.bz2 \
64         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.bz2
65 install -D -m 644 bootstrapfs-%{nodefamily}.tar \
66         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar
67
68 for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
69     NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
70     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 \
71                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 
72     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar \
73                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar 
74 done
75
76 popd
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(-,root,root,-)
83 /var/www/html/boot/bootstrapfs*.tar.bz2
84
85 %files plain
86 %defattr(-,root,root,-)
87 /var/www/html/boot/bootstrapfs*.tar
88
89 %changelog
90 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
91 - for building on fedora12
92
93 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
94 - cosmetic change in message at build-time
95
96 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
97 - can use groups in the pkgs file with +++ for space
98
99 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
100 - bugfix for when a .post script is not needed
101
102 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
103 - search post-install scripts (.post) in path (distro, then planetlab)
104 - mostly useful for externally-defined pldistros
105
106 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
107 - fix build bug when dealing with extensions
108
109 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
110 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
111
112 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
113 - cosmetic changes in build: displays duration, and shows up in summary
114
115 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
116 - Do not overwrite yumgroups.xml upon updates of noderepo
117
118 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
119 - uses the right yum.conf when building images
120
121 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
122 - rpm release tag does not need pldistro as it is already part of the rpm name
123
124 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
125 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
126 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
127
128 * Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
129 - search more carefully for alternate pkgs files
130 - handling of sysconfig/crontab and creation of site_admin reviewed
131 - (this tag is set with module-tag.py)
132
133 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
134 - Initial build.
135
136 %define module_current_branch 1.0