Setting tag bootstrapfs-2.0-7
[bootstrapfs.git] / noderepo.spec
1 # build is expected to export the following rpm variables
2 # %{distroname}     : e.g. Fedora
3 # %{distrorelease}  : e.g. 8
4 # %{node_rpms_plus} : as a +++ separated list of rpms from the build dir
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define obsolete_nodefamily %{pldistro}-%{_arch}
8
9 %define name noderepo-%{nodefamily}
10 %define version 2.0
11 %define taglevel 7
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 Vendor: OneLab
18 Packager: PlanetLab Europe <build@onelab.eu>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 Summary: The yum repository for nodes, to be installed on the myplc-side
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Base
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30 # other archs must be able to install this
31 BuildArch: noarch
32
33 BuildRequires: rsync 
34 Requires: myplc
35
36 # 5.0 now has 3-fold nodefamily
37 %define obsolete_nodefamily %{pldistro}-%{_arch}
38 Obsoletes: noderepo-%{obsolete_nodefamily}
39
40 %define debug_package %{nil}
41
42 %description
43 This rpm contains all the rpms designed for running on a PlanetLab node
44 they come organized into a yum repository 
45
46 %prep
47 %setup -q
48
49 %build
50 echo nothing to do at build time for noderepo
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 repo=%{nodefamily}
56 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
57 rpms=$(echo %{node_rpms_plus} | sed -e 's,+++, ,g')
58 for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
59 ### yumgroups
60 install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/yumgroups.xml
61 # do not do this yet, as plc.d/packages will do it anyway
62 #createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 # it would at first glance seem to make sense to invoke service plc start gpg here as well, 
69 # as noderepo might get installed before myplc gets even started 
70 # this however exhibit a deadlock, as rpm --almatches -e gpg-pubkey waits for transaction lock
71 # that is help by the calling yum/rpm
72 service plc start packages
73
74 %files
75 %defattr(-,root,root,-)
76 /var/www/html/install-rpms/%{nodefamily}
77 # don't overwrite yumgroups.xml if exists
78 %config(noreplace) /var/www/html/install-rpms/%{nodefamily}/yumgroups.xml
79
80 %changelog
81 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
82 - yum repo template for f14 nodes
83 - tweaks the way /etc/plc.d/packages works
84
85 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
86 - add sha1sum
87 - module name changes
88
89 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
90 - support different flavours of vservers on nodes
91
92 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
93 - fix unmatched $ in URL svn keywords
94
95 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
96 - choice between various pldistros is not made at build time, but at run time
97 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
98 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
99 - the https method does not work on fedora 12, and GPG is used below anyway
100
101 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
102 - new slicerepo package for exposing stuff to slivers
103
104 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
105 - first working version of 5.0:
106 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
107 - nodefailiy is 3-fold with pldistro-fcdistro-arch
108 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
109
110 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
111 - for building on fedora12
112
113 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
114 - cosmetic change in message at build-time
115
116 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
117 - can use groups in the pkgs file with +++ for space
118
119 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
120 - bugfix for when a .post script is not needed
121
122 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
123 - search post-install scripts (.post) in path (distro, then planetlab)
124 - mostly useful for externally-defined pldistros
125
126 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
127 - fix build bug when dealing with extensions
128
129 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
130 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
131
132 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
133 - cosmetic changes in build: displays duration, and shows up in summary
134
135 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
136 - Do not overwrite yumgroups.xml upon updates of noderepo
137
138 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
139 - uses the right yum.conf when building images
140
141 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
142 - rpm release tag does not need pldistro as it is already part of the rpm name
143
144 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
145 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
146 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
147
148 * Tue Mar 4 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
149 - Initial build.
150
151 %define module_current_branch 1.0