cross-module name change for more consistency
[bootstrapfs.git] / noderepo.spec
1 #
2 # $Id: bootstrapfs.spec 7668 2008-01-08 11:49:43Z thierry $
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/BootstrapFS/trunk/bootstrapfs.spec $
5
6 # build is expected to export the following rpm variables
7 # %{distroname}     : e.g. Fedora
8 # %{distrorelease}  : e.g. 8
9 # %{node_rpms_plus} : as a +++ separated list of rpms from the build dir
10
11 %define name noderepo-%{distroname}-%{_arch}
12 %define version 4.2
13 %define taglevel 1
14
15 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: The initial content of the yum repository for nodes
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Base
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30
31 BuildRequires: rsync createrepo
32
33 %define debug_package %{nil}
34
35 %description
36 This rpm contains all the rpms designed for running on a PlanetLab node
37 they come organized into a yum repository 
38
39 %prep
40 %setup -q
41
42 %build
43 echo nothing to do at build time for noderepo
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 pushd BootstrapFS
49 repo=planetlab-%{distroname}-%{_arch}
50 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
51 rpms=$(echo %{node_rpms_plus} | sed -e s,+++, ,g)
52 for rpm in $rpms; do rsync $RPM_BUILD_ROOT/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
53 ### yumgroups
54 install -D -m 644 $RPM_BUILD_ROOT/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
55 createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
56 popd
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62
63
64 %files
65 %defattr(-,root,root,-)
66 /var/www/html/install-rpms/planetlab-%{distroname}-%{_arch}
67
68 %changelog
69 * Tue Mar 4 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
70 - Initial build.