Setting tag nodeimage-5.2-6
[bootstrapfs.git] / noderepo.spec
1 # build is expected to export the following rpm variables
2 # %{distroname}     : e.g. Fedora
3 # %{distrorelease}  : e.g. 8
4 # %{node_rpms_plus} : as a +++ separated list of rpms from the build dir
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define obsolete_nodefamily %{pldistro}-%{_arch}
8
9 %define name noderepo-%{nodefamily}
10 %define version 5.2
11 %define taglevel 6
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 # we don't really need the standard postinstall process from rpm that
18 # strips files and byte-compiles python files. all files in this
19 # package are comming from other rpm files and they've already went
20 # through this post install processing. - baris
21 %define __os_install_post %{nil}
22
23 Vendor: OneLab
24 Packager: PlanetLab Europe <build@onelab.eu>
25 Distribution: PlanetLab %{plrelease}
26 URL: %{SCMURL}
27
28 Summary: The yum repository for nodes, to be installed on the myplc-side
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: BSD
33 Group: System Environment/Base
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36 # other archs must be able to install this
37 BuildArch: noarch
38
39 BuildRequires: rsync 
40 Requires: myplc
41
42 # 5.0 now has 3-fold nodefamily
43 %define obsolete_nodefamily %{pldistro}-%{_arch}
44 Obsoletes: noderepo-%{obsolete_nodefamily}
45
46 %define debug_package %{nil}
47
48 %description
49 This rpm contains all the rpms designed for running on a PlanetLab node
50 they come organized into a yum repository 
51
52 %prep
53 %setup -q
54
55 %build
56 echo nothing to do at build time for noderepo
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 repo=%{nodefamily}
62 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
63 rpms=$(echo %{node_rpms_plus} | sed -e 's,+++, ,g')
64 for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
65 ### yumgroups
66 install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/yumgroups.xml
67 # do not do this yet, as plc.d/packages will do it anyway
68 #createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 # it would at first glance seem to make sense to invoke service plc start gpg here as well, 
75 # as noderepo might get installed before myplc gets even started 
76 # this however exhibit a deadlock, as rpm --almatches -e gpg-pubkey waits for transaction lock
77 # that is help by the calling yum/rpm
78 if [ ! -e /bin/systemctl ] ; then
79    echo "Systemd is not there. Just starting PLC to handle packages (may fail if PLC is not configured) ..."
80    service plc start packages
81 elif /bin/systemctl status plc >/dev/null ; then
82    echo "Restarting PLC to handle packages ..."
83    service plc restart packages
84 else
85    echo "PLC is not running. Skipping a restart ..."
86 fi
87
88 %files
89 %defattr(-,root,root,-)
90 /var/www/html/install-rpms/%{nodefamily}
91 # don't overwrite yumgroups.xml if exists
92 %config(noreplace) /var/www/html/install-rpms/%{nodefamily}/yumgroups.xml
93
94 %changelog
95 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-6
96 - fix for f22 and dnf.conf
97
98 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-5
99 - the yum config for nodes on f21 and f22
100 - define a new config_file for /etc/dnf/dnf.conf so that /etc/yum.myplc.d
101 - is taken into account on f22
102
103 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-4
104 - minor change; start plc packages only at run-time, not build-time
105 - only available on systems that have systemctl
106
107 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-4
108 - Post-install fix: trying to start PLC only when it is running, in order to avoid false-positive error message during build.
109
110 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-3
111 - template for f20 yum config
112
113 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-2
114 - more timestamps during build
115
116 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-1
117 - add support for f18 yum config
118
119 * Mon Feb 11 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodeimage-2.1-4
120
121 * Mon Nov 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-3
122 - fix /etc/plc.d/packages for empty install dirs
123
124 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-2
125 - exclude slice repos when running plc.d/packages start
126
127 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-1
128 - renamed as nodeimage - works on both mainline and lxc
129
130 * Thu Feb 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-14
131 - changes needed for build with yumexcludes defined in a separate pkgs file
132
133 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
134 - plc.d/packages: rewrote comments about some corner cases where it fails
135 - plc.d/packages: marginally more robust
136
137 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
138 - minor tweak in plc.d/packages
139
140 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - bootstrapfs-2.0-11
141 - sl6 templates
142
143 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-10
144 - bugfix for multi-flavour deployments
145
146 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-9
147 - for multi-flavours : 'packages' step in plc.d now handles vserver links and related hacks in yumgroups
148
149 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-8
150 - no semantic change - attempt to speed up build
151
152 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
153 - yum repo template for f14 nodes
154 - tweaks the way /etc/plc.d/packages works
155
156 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
157 - add sha1sum
158 - module name changes
159
160 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
161 - support different flavours of vservers on nodes
162
163 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
164 - fix unmatched $ in URL svn keywords
165
166 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
167 - choice between various pldistros is not made at build time, but at run time
168 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
169 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
170 - the https method does not work on fedora 12, and GPG is used below anyway
171
172 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
173 - new slicerepo package for exposing stuff to slivers
174
175 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
176 - first working version of 5.0:
177 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
178 - nodefailiy is 3-fold with pldistro-fcdistro-arch
179 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
180
181 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
182 - for building on fedora12
183
184 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
185 - cosmetic change in message at build-time
186
187 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
188 - can use groups in the pkgs file with +++ for space
189
190 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
191 - bugfix for when a .post script is not needed
192
193 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
194 - search post-install scripts (.post) in path (distro, then planetlab)
195 - mostly useful for externally-defined pldistros
196
197 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
198 - fix build bug when dealing with extensions
199
200 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
201 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
202
203 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
204 - cosmetic changes in build: displays duration, and shows up in summary
205
206 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
207 - Do not overwrite yumgroups.xml upon updates of noderepo
208
209 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
210 - uses the right yum.conf when building images
211
212 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
213 - rpm release tag does not need pldistro as it is already part of the rpm name
214
215 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
216 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
217 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
218
219 * Tue Mar 4 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
220 - Initial build.
221
222 %define module_current_branch 1.0