Setting tag codemux-0.1-15
[codemux.git] / codemux.spec
index 50508e4..a29c3bf 100644 (file)
@@ -1,6 +1,8 @@
 %define name codemux 
 %define version 0.1
-%define release 6%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define taglevel 15
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Summary: CoDemux - HTTP port DeMux
 Name: %{name} 
@@ -11,10 +13,11 @@ Group: System Environment/Base
 Source: %{name}-%{version}.tar.gz
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.0
-URL: http://codeen.cs.princeton.edu/
+Distribution: PlanetLab %{plrelease}
+URL: %{SCMURL}
+#URL: http://codeen.cs.princeton.edu/
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-Requires: vnet
+#Requires: vnet
 
 %description
 codemux is a privileged port (80) sharing service that passes traffic to and from slices via localhost ports.
@@ -26,12 +29,12 @@ codemux is a privileged port (80) sharing service that passes traffic to and fro
 make clean
 
 %build
-make
+make RPM_VERSION=%{version}.%{taglevel}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 make INSTALL_ROOT=$RPM_BUILD_ROOT install
+install -D -m 644 codemux.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/codemux
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -39,14 +42,15 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(0644,root,root)
 %attr(0755,root,root) %{_initrddir}/codemux
-%config /etc/codemux/codemux.conf
+%config(noreplace) /etc/codemux/codemux.conf
 %attr(0755,root,root) /usr/sbin/codemux
+%{_sysconfdir}/logrotate.d/codemux
 
 %post
-chkconfig codemux reset
+chkconfig --add codemux
 
 if [ -z "$PL_BOOTCD" ]; then
-    /etc/init.d/codemux restart
+    /etc/init.d/codemux condrestart
 fi
 
 %preun
@@ -61,6 +65,31 @@ if [ "$1" = 0 ]; then
 fi
 
 %changelog
+* Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - codemux-0.1-15
+- no semantic change - just fixed specfile for git URL
+
+* Tue Mar 09 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - CoDemux-0.1-14
+- introduce an IP field
+
+* Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - CoDemux-0.1-13
+- Add condrestart to the initscript and add a way to limit codemux to one IP.
+
+* Fri Jun 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - CoDemux-0.1-12
+- 
+- KyoungSoo added fix to prevent failure with new compilers
+- 
+
+* Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - CoDemux-0.1-11
+- 
+
+* Thu Apr 24 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - CoDemux-0.1-10
+- 
+- Examples in conf file are enough.  Removed PLC specific entries.
+- 
+
+* Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - CoDemux-0.1-7 CoDemux-0.1-8
+- 
+
 * Sun Apr 22 2007 KYOUNGSOO PARK <kyoungso@park.cs.princeton.edu> - 
 - Initial build.