restored former specfile as it contains taglevel information needed by module-tag
[codemux.git] / codemux.spec
index e0c4c89..b7d2e21 100644 (file)
@@ -1,6 +1,13 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name codemux 
 %define version 0.1
-%define release 8%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define taglevel 7
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Summary: CoDemux - HTTP port DeMux
 Name: %{name} 
@@ -11,8 +18,9 @@ Group: System Environment/Base
 Source: %{name}-%{version}.tar.gz
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.0
-URL: http://codeen.cs.princeton.edu/
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
+#URL: http://codeen.cs.princeton.edu/
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 #Requires: vnet
 
@@ -26,7 +34,7 @@ codemux is a privileged port (80) sharing service that passes traffic to and fro
 make clean
 
 %build
-make
+make RPM_VERSION=%{version}.%{taglevel}
 
 %install
 rm -rf $RPM_BUILD_ROOT