ready for tagging
[codemux.git] / codemux.spec
index 101464d..bd065a6 100644 (file)
@@ -1,18 +1,32 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name codemux 
 %define version 0.1
-%define release 4%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define taglevel 7
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Summary: CoDemux - HTTP port DeMux
-Name: codemux
+Name: %{name} 
 Version: %{version}
 Release: %{release}
 License: Private
 Group: System Environment/Base
-URL: http://codeen.cs.princeton.edu/
-Source0: %{name}-%{version}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-buildroot
+Source: %{name}-%{version}.tar.gz
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
+#URL: http://codeen.cs.princeton.edu/
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+#Requires: vnet
 
 %description
+codemux is a privileged port (80) sharing service that passes traffic to and from slices via localhost ports.
+
 
 %prep
 %setup -q
@@ -34,7 +48,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(0644,root,root)
 %attr(0755,root,root) %{_initrddir}/codemux
 %config /etc/codemux/codemux.conf
-%attr(0755,root,root) /usr/local/planetlab/sbin/codemux
+%attr(0755,root,root) /usr/sbin/codemux
 
 %post
 chkconfig codemux reset