Tagging module CoDemux - CoDemux-0.1-12
[codemux.git] / codemux.spec
index 5e9eb8f..d61582c 100644 (file)
@@ -1,6 +1,13 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name codemux 
 %define version 0.1
-%define release 6%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define taglevel 12
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Summary: CoDemux - HTTP port DeMux
 Name: %{name} 
@@ -11,8 +18,9 @@ Group: System Environment/Base
 Source: %{name}-%{version}.tar.gz
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.0
-URL: http://codeen.cs.princeton.edu/
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
+#URL: http://codeen.cs.princeton.edu/
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 #Requires: vnet
 
@@ -26,12 +34,12 @@ codemux is a privileged port (80) sharing service that passes traffic to and fro
 make clean
 
 %build
-make
+make RPM_VERSION=%{version}.%{taglevel}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 make INSTALL_ROOT=$RPM_BUILD_ROOT install
+install -D -m 644 codemux.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/codemux
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -41,6 +49,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(0755,root,root) %{_initrddir}/codemux
 %config /etc/codemux/codemux.conf
 %attr(0755,root,root) /usr/sbin/codemux
+%{_sysconfdir}/logrotate.d/codemux
 
 %post
 chkconfig codemux reset
@@ -61,6 +70,22 @@ if [ "$1" = 0 ]; then
 fi
 
 %changelog
+* Fri Jun 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - CoDemux-0.1-12
+- 
+- KyoungSoo added fix to prevent failure with new compilers
+- 
+
+* Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - CoDemux-0.1-11
+- 
+
+* Thu Apr 24 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - CoDemux-0.1-10
+- 
+- Examples in conf file are enough.  Removed PLC specific entries.
+- 
+
+* Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - CoDemux-0.1-7 CoDemux-0.1-8
+- 
+
 * Sun Apr 22 2007 KYOUNGSOO PARK <kyoungso@park.cs.princeton.edu> - 
 - Initial build.