Support for PLC redirection and a single-entry configuration. updated the conf file
[codemux.git] / codemux.spec
index b212ece..e0c4c89 100644 (file)
@@ -1,14 +1,24 @@
-Summary: CoDemux - HTTP port demultiplexer
-Name: codemux
-Version: 0.4
-Release: 1
+%define name codemux 
+%define version 0.1
+%define release 8%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+
+Summary: CoDemux - HTTP port DeMux
+Name: %{name} 
+Version: %{version}
+Release: %{release}
 License: Private
 Group: System Environment/Base
+Source: %{name}-%{version}.tar.gz
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab 3.0
 URL: http://codeen.cs.princeton.edu/
-Source0: %{name}-%{version}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+#Requires: vnet
 
 %description
+codemux is a privileged port (80) sharing service that passes traffic to and from slices via localhost ports.
+
 
 %prep
 %setup -q
@@ -21,22 +31,21 @@ make
 %install
 rm -rf $RPM_BUILD_ROOT
 
-make install
+make INSTALL_ROOT=$RPM_BUILD_ROOT install
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(0644,root,root,)
+%defattr(0644,root,root)
 %attr(0755,root,root) %{_initrddir}/codemux
 %config /etc/codemux/codemux.conf
-%attr(0755,root,root) /usr/local/planetlab/sbin/codemux
+%attr(0755,root,root) /usr/sbin/codemux
 
 %post
 chkconfig codemux reset
 
 if [ -z "$PL_BOOTCD" ]; then
-    /sbin/ldconfig
     /etc/init.d/codemux restart
 fi
 
@@ -51,8 +60,6 @@ if [ "$1" = 0 ]; then
     fi
 fi
 
-%doc
-
 %changelog
 * Sun Apr 22 2007 KYOUNGSOO PARK <kyoungso@park.cs.princeton.edu> - 
 - Initial build.