fix mac address are truncated problem when compiling ulogd with -D_FORTIFY_SOURCE...
[distributedratelimiting.git] / DistributedRateLimiting.spec
1 %define url $URL: http://svn.planet-lab.org/svn/DistributedRateLimiting/trunk/DistributedRateLimiting.spec $
2
3 # please keep these three lines as they are used by the tagging script
4 # see build/module-tag.py for details
5 %define name DistributedRateLimiting
6 %define version 0.1
7 %define taglevel 0
8
9 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Name:           %{name}
12 Version:        %{version}
13 Release:        %{release}
14 Summary:        DRL: Distributed Rate Limiting
15 Group:          Network/Monitoring
16 License:        Academic
17 URL: %(echo %{url} | cut -d ' ' -f 2)
18 Source0:        %{name}-%{version}.tar.bz2
19 Buildroot:      %{_tmppath}/%{name}-buildroot
20 BuildRequires:  libxml2-devel
21 Requires:       libxml2
22 Provides:       DistributedRateLimiting
23
24 %description
25 DistributedRateLimiting - Coordinates rate limiting among multiple nodes as if
26 was a centralized limiter.
27
28 %prep
29 %setup
30 aclocal
31 autoconf
32 %configure --without-zookeeper
33
34 %build
35 make
36
37 %install
38 rm -rf %{buildroot}
39 mkdir -p %{buildroot}/%{_sysconfdir}
40 mkdir -p %{buildroot}/%{_libdir}/ulogd
41 mkdir -p %{buildroot}/%{_sbindir}/sbin
42 mkdir -p %{buildroot}/%{_mandir}/man8
43 make DESTDIR=%{buildroot} install
44
45 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/init.d
46 install ulogd.init %{buildroot}/%{_sysconfdir}/rc.d/init.d/ulogd
47 install ulogd.8 %{buildroot}/%{_mandir}/man8/ulogd.8
48 install drl.xml %{buildroot}/%{_sysconfdir}
49 install -D -m 644 ulogd.logrotate %{buildroot}/%{_sysconfdir}/logrotate.d/ulogd
50                 
51 %clean
52 rm -rf %{buildroot}
53
54 %files
55 %defattr(0644,root,root,0755)
56 %attr(0755,root,root) %{_sbindir}/ulogd
57 %config %{_sysconfdir}/ulogd.conf
58 %config %{_sysconfdir}/drl.xml
59 %{_sysconfdir}/logrotate.d/ulogd
60 %attr(0755,root,root) %{_sysconfdir}/rc.d/init.d/ulogd
61 %{_mandir}/man8/*
62 %dir %{_libdir}/ulogd
63 %{_libdir}/ulogd/ulogd_BASE.so
64 %{_libdir}/ulogd/ulogd_LOCAL.so
65 %{_libdir}/ulogd/ulogd_LOGEMU.so
66 %{_libdir}/ulogd/ulogd_OPRINT.so
67 %{_libdir}/ulogd/ulogd_PWSNIFF.so
68 %{_libdir}/ulogd/ulogd_SYSLOG.so
69 %{_libdir}/ulogd/ulogd_DRL.so
70 %doc COPYING AUTHORS README
71 %doc doc/ulogd.txt doc/ulogd.a4.ps doc/ulogd.html
72 %doc drl/DRL-LICENSE
73
74 %changelog
75 * Tue Oct 14 2008 Kevin Webb <kcwebb@cs.ucsd.edu> - DistributedRateLimiting-0.1
76 - Created this spec file.  Doing my best to import the DRL code into the PlanetLab build system.
77
78
79 %define module_current_branch 0.1