d0f1897027240c0d32d3e4de6a83af3b77742a3b
[drupal.git] / drupal.spec
1 #
2 # $Id$
3 #
4
5 %define name drupal
6 %define version 4.7
7 %define taglevel 11
8
9 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Packager: PlanetLab Central <support@planet-lab.org>
12
13 # remain compliant with former planetlab practices
14 %define drupaldir /var/www/html
15 Name: %{name}
16 Version:  %{version}
17 Release:  %{release}
18 Summary: An open-source content-management platform
19
20 Group: Applications/Publishing
21 License: GPLv2+        
22 URL: http://www.drupal.org
23 Source0: http://ftp.osuosl.org/pub/drupal/files/projects/%{name}-%{version}.%{taglevel}.tar.gz
24 #Source1: drupal.conf
25 Source2: drupal-cron
26
27 BuildArch: noarch
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
29 Requires: php, php-gd, php-mbstring, wget
30
31 %description
32 Equipped with a powerful blend of features, Drupal is a Content Management 
33 System written in PHP that can support a variety of websites ranging from
34 personal weblogs to large community-driven websites.  Drupal is highly
35 configurable, skinnable, and secure.
36
37 %prep
38
39 %setup -q -n %{name}-%{version}.%{taglevel}
40
41 %build
42
43 %install
44 rm -rf %{buildroot}
45 install -d %{buildroot}%{drupaldir}
46 cp -pr * %{buildroot}%{drupaldir}
47 cp -pr .htaccess %{buildroot}%{drupaldir}
48 mkdir -p %{buildroot}%{_docdir}
49 install -D -p -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/cron.hourly/drupal 
50 mkdir %{buildroot}%{drupaldir}/files
51
52 %clean
53 rm -rf %{buildroot}
54
55 %files
56 %defattr(-,root,root,-)
57 %doc CHANGELOG.txt INSTALL* LICENSE* MAINTAINERS.txt UPGRADE.txt 
58 %{drupaldir}
59 %config(noreplace) %{drupaldir}/.htaccess
60 %exclude %{drupaldir}/CHANGELOG.txt
61 %exclude %{drupaldir}/INSTALL* 
62 %exclude %{drupaldir}/LICENSE* 
63 %exclude %{drupaldir}/MAINTAINERS.txt 
64 %exclude %{drupaldir}/UPGRADE.txt
65 %config(noreplace) %{drupaldir}/sites/default
66 %attr(755,root,apache) %{_sysconfdir}/cron.hourly/drupal
67 %dir %attr(775,root,apache) %{drupaldir}/files
68
69 %changelog
70 * Fri Jan 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
71 - plain drupal 4.7.11