Codemux support: react to changes in the xid of a connection to update the correspond...
[fprobe-ulog.git] / fprobe-ulog.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 # please keep these three lines as they are used by the tagging script
7 # see build/module-tag.py for details
8 %define name fprobe-ulog
9 %define version 1.1.2
10 %define taglevel 6
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Name:           %{name}
15 Version:        %{version}
16 Release:        %{release}
17 Summary:        fprobe-ulog: a NetFlow probe
18 Group:          Network/Monitoring
19 License:        GPL
20 #URL:           http://fprobe.sourceforge.net
21 URL: %(echo %{url} | cut -d ' ' -f 2)
22 Source0:        %{name}-%{version}.tar.bz2
23 Buildroot:      %{_tmppath}/%{name}-buildroot
24 Provides:       fprobe-ulog
25
26 %description
27 fprobe-ulog - libipulog-based tool that collect network traffic data and emit
28 it as NetFlow flows towards the specified collector. PlanetLab version.
29
30 %prep
31 %setup -q
32
33 %build
34 ./configure --sbindir=/sbin --mandir=%{_mandir} --enable-uptime_trick=no $EXTRA_OPTIONS
35 make
36
37 %install
38 rm -rf %{buildroot}
39 make install DESTDIR=%{buildroot}
40 install -d -v %{buildroot}/etc/init.d
41 mkdir -p %{buildroot}/var/local/fprobe
42 install -m 755 -v fprobe-initscript %{buildroot}/etc/init.d/fprobe-ulog
43 gzip --best %{buildroot}%{_mandir}/man8/fprobe-ulog.8
44
45 %clean
46 rm -rf %{buildroot}
47
48 %files
49 %defattr(-,root,root)
50 %doc AUTHORS ChangeLog NEWS README COPYING TODO
51 /etc/init.d/fprobe-ulog
52 /sbin/fprobe-ulog
53 /var/local/fprobe
54 %{_mandir}/man8/fprobe-ulog.8.gz
55
56 %post
57 chkconfig --add fprobe-ulog
58 chkconfig fprobe-ulog on
59 if [ "$PL_BOOTCD" != "1" ] ; then
60         service fprobe-ulog restart
61     fi
62
63 %preun
64 # 0 = erase, 1 = upgrade
65 if [ "$1" -eq 0 ]; then
66     if [ "$PL_BOOTCD" != "1" ] ; then
67         service fprobe-ulog stop
68     fi
69     chkconfig fprobe-ulog off
70     chkconfig --del fprobe-ulog
71 fi
72
73
74 %changelog
75 * Sun Sep 14 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - fprobe-ulog-1.1.2-6
76 - Codemux support: react to changes in the xid of a connection to update the corresponding flow record.
77
78 * Wed Sep 10 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - fprobe-ulog-1.1.2-5
79 - Bug fix, although not major.
80
81 * Tue Jul 01 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - fprobe-ulog-1.1.2-4
82 - This change is required for PlanetFlow data collection on PLE. It makes fprobe data accessible to non-root users such
83 - as pl[e]_netflow.
84
85 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - fprobe-ulog-1.1.2-3
86
87