use our mirror
[gnuradio.git] / gnuradio.spec
1 # SPEC file for gnuradio
2 #
3 #
4 # Source: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
5 #
6 # Signature: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz.sig
7 #
8 %define name gnuradio
9 %define version 3.2.2
10 %define release 21
11 %define actual_name %{name}-%{version}
12
13 %define module_taglevel_varname release
14
15 Name: %{name}
16 Summary: GNU software radio
17 Version: %{version}
18 Release: %{release}
19 License: GPLv3
20 URL: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
21 Group: Productivity/Hamradio/Other
22 Source: %{actual_name}.tar.gz
23
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
25
26
27 BuildRequires: python python-numeric PyQt4 swig fftw sdcc gsl libtool 
28 BuildRequires: subversion guile cppunit gcc gcc-c++ make
29 BuildRequires: boost-devel >= 1.35
30 BuildRequires: python-devel fftw-devel boost-devel gsl-devel libusb-devel
31 BuildRequires: cppunit-devel
32
33
34 Requires: python python-numeric PyQt4 swig fftw libtool
35 Requires: boost >= 1.35
36
37 %description
38 gnuradio is a free software radio toolkit
39
40 %prep
41
42 %setup -q -n %{actual_name}
43
44
45 %build
46 export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
47 # Following export PATH is a dirty hack to let gnuradio configure find sdcc
48 export PATH=$PATH:/usr/libexec/sdcc
49 ./bootstrap
50 #./configure
51 %configure --disable-doxygen
52 make
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 mkdir $RPM_BUILD_ROOT
57
58 #make DESTDIR=$RPM_BUILD_ROOT install
59 %makeinstall
60
61 %post
62 echo 'export PYTHONPATH=/usr/lib/python2.5/site-packages/' >> ~/.bashrc
63 /sbin/ldconfig
64
65 %postun
66 /sbin/ldconfig
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71
72
73 %package -n %{name}-devel
74 Summary: gnuradio devel files
75 Version: %{version}
76 Release: %{release}
77 Group:   Productivity/Hamradio/Other
78 Requires: gnuradio
79
80 %description -n %{name}-devel
81 Devel package of gnuradio
82
83 %post -n %{name}-devel
84 /sbin/ldconfig
85
86 %postun -n %{name}-devel
87 /sbin/ldconfig
88
89 %files -n %{name}-devel
90 %defattr(-,root,root,-)
91 %{_includedir}/*
92 %{_libdir}/pkgconfig/*
93 %{_libdir}/lib*.la
94
95
96 %files -n %{name}
97 %defattr(-,root,root,-)
98 %{_bindir}/*
99 %dir /etc/gnuradio
100 %config /etc/gnuradio/*
101 %{_libdir}/lib*so*
102 %{_libdir}/python*/site-packages/
103 %{_datadir}/doc/*
104 %dir %{_datadir}/gnuradio
105 %{_datadir}/gnuradio/*
106 %dir %{_datadir}/usrp
107 %{_datadir}/usrp/*
108 # TO FIX: if the 2 following commands are removed, the rpmbuild fails!
109 # It's w+eird because rev2 and rev3 directories are indeed created at the 
110 # right place (/usr/share/rev*) when the rpm is installed...
111 %{_datadir}/rev2/*
112 %{_datadir}/rev4/*
113 %doc AUTHORS README README.hacking ChangeLog NEWS INSTALL COPYING
114
115
116
117
118
119 %changelog -n gnuradio
120 * Wed Oct 8 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.1
121 - fixed lots of missing parameters...
122
123 * Thu Oct 1 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.0
124 - derived from previous gnuradio-3.2 spec file written by Ben Yahmed Maher <ben.yahmed.maher@gmail.com>. Changes made to compile the new 3.2.2 gnuradio version on F10 with both USRP and USRP2 hardware enabled.
125
126 * Wed Apr 1 2009  Ben Yahmed Maher <ben.yahmed.maher@gmail.com> 3.2.2-1.2
127 - change to svn 10720 with fedora 10
128
129
130