undo previous change, build now fixed in sge.spec
[gnuradio.git] / gnuradio.spec
1 # SPEC file for gnuradio
2 #
3 #
4 # Source: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
5 #
6 # Signature: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz.sig
7 #
8 %define name gnuradio
9 %define version 3.2.2
10 %define release 21
11 %define actual_name %{name}-%{version}
12
13 %define module_taglevel_varname release
14
15 Name: %{name}
16 Summary: GNU software radio
17 Version: %{version}
18 Release: %{release}
19 License: GPLv3
20 URL: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
21 Group: Productivity/Hamradio/Other
22 Source: %{actual_name}.tar.gz
23
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
25
26
27 BuildRequires: python python-numeric PyQt4 swig fftw sdcc gsl libtool 
28 BuildRequires: subversion guile cppunit gcc gcc-c++ make
29 BuildRequires: boost-devel >= 1.35
30 BuildRequires: python-devel fftw-devel boost-devel gsl-devel libusb-devel
31 BuildRequires: cppunit-devel
32
33
34 Requires: python python-numeric PyQt4 swig fftw libtool
35 Requires: boost >= 1.35
36
37 %description
38 gnuradio is a free software radio toolkit
39
40 %prep
41
42 %setup -q -n %{actual_name}
43
44
45 %build
46 export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
47 # Following export PATH is a dirty hack to let gnuradio configure find sdcc
48 export PATH=$PATH:/usr/libexec/sdcc
49 ./bootstrap
50 #./configure
51 %configure --disable-doxygen
52 make
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 mkdir $RPM_BUILD_ROOT
57
58 #make DESTDIR=$RPM_BUILD_ROOT install
59 %makeinstall
60
61 %post
62 echo 'export PYTHONPATH=/usr/lib/python2.5/site-packages/' >> ~/.bashrc
63 /sbin/ldconfig
64
65 %postun
66 /sbin/ldconfig
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71
72
73
74
75
76
77 %package -n %{name}-devel
78 Summary: gnuradio devel files
79 Version: %{version}
80 Release: %{release}
81 Group:   Productivity/Hamradio/Other
82 Requires: gnuradio
83
84 %description -n %{name}-devel
85 Devel package of gnuradio
86
87 %post -n %{name}-devel
88 /sbin/ldconfig
89
90 %postun -n %{name}-devel
91 /sbin/ldconfig
92
93 %files -n %{name}-devel
94 %defattr(-,root,root,-)
95 %{_includedir}/*
96 %{_libdir}/pkgconfig/*
97 %{_libdir}/lib*.la
98
99
100 %files -n %{name}
101 %defattr(-,root,root,-)
102 %{_bindir}/*
103 %dir /etc/gnuradio
104 %config /etc/gnuradio/*
105 %{_libdir}/lib*so*
106 %{_libdir}/python2.5/site-packages/
107 %{_datadir}/doc/*
108 %dir %{_datadir}/gnuradio
109 %{_datadir}/gnuradio/*
110 %dir %{_datadir}/usrp
111 %{_datadir}/usrp/*
112 # TO FIX: if the 2 following commands are removed, the rpmbuild fails!
113 # It's w+eird because rev2 and rev3 directories are indeed created at the 
114 # right place (/usr/share/rev*) when the rpm is installed...
115 %{_datadir}/rev2/*
116 %{_datadir}/rev4/*
117 %doc AUTHORS README README.hacking ChangeLog NEWS INSTALL COPYING
118
119
120
121
122
123 %changelog -n gnuradio
124 * Wed Oct 8 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.1
125 - fixed lots of missing parameters...
126
127 * Thu Oct 1 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.0
128 - derived from previous gnuradio-3.2 spec file written by Ben Yahmed Maher <ben.yahmed.maher@gmail.com>. Changes made to compile the new 3.2.2 gnuradio version on F10 with both USRP and USRP2 hardware enabled.
129
130 * Wed Apr 1 2009  Ben Yahmed Maher <ben.yahmed.maher@gmail.com> 3.2.2-1.2
131 - change to svn 10720 with fedora 10
132
133
134