missing file in package
[gnuradio.git] / gnuradio.spec
1 # SPEC file for gnuradio
2 #
3 #
4 # Source: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
5 #
6 # Signature: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz.sig
7 #
8 %define name gnuradio
9 %define version 3.2.2
10 %define release 21
11 %define actual_name %{name}-%{version}
12
13 %define module_taglevel_varname release
14
15 Name: %{name}
16 Summary: GNU software radio
17 Version: %{version}
18 Release: %{release}
19 License: GPLv3
20 URL: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
21 Group: Productivity/Hamradio/Other
22 Source0: %{actual_name}.tar.gz
23 Source1:        10-usrp.rules
24 Patch0:         gnuradio-3.2-libtool.patch
25
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
27
28
29 BuildRequires: python python-numeric PyQt4 swig fftw sdcc gsl libtool 
30 BuildRequires: subversion guile cppunit gcc gcc-c++ make
31 BuildRequires: boost-devel >= 1.35
32 BuildRequires: python-devel fftw-devel boost-devel gsl-devel libusb-devel
33 BuildRequires: cppunit-devel
34
35
36 Requires: python python-numeric PyQt4 swig fftw libtool
37 Requires: boost >= 1.35
38
39 %description
40 gnuradio is a free software radio toolkit
41
42 %prep
43 %setup -q -n %{actual_name}
44 %patch0 -p1 -b .libtool
45
46
47 %build
48 export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
49 # dirty hack to let gnuradio configure find sdcc
50 export PATH=%{_libexecdir}/sdcc:$PATH
51
52 ########## the bootstrap script basically reruns autoconf and automake
53 %if "%{distro}" == "Fedora" && %{distrorelease} >= 12
54 autoreconf -i
55 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
56 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
57 %else
58 bash -x ./bootstrap
59 %endif
60
61 %configure --disable-doxygen
62 make %{?_smp_mflags}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 make install DESTDIR=$RPM_BUILD_ROOT
67 install -D -m0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/10-usrp.rules
68
69 #make DESTDIR=$RPM_BUILD_ROOT install
70 %makeinstall
71
72 %post
73 echo 'export PYTHONPATH=/usr/lib/python2.5/site-packages/' >> ~/.bashrc
74 /sbin/ldconfig
75
76 %postun
77 /sbin/ldconfig
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82
83
84 %package -n %{name}-devel
85 Summary: gnuradio devel files
86 Version: %{version}
87 Release: %{release}
88 Group:   Productivity/Hamradio/Other
89 Requires: gnuradio
90
91 %description -n %{name}-devel
92 Devel package of gnuradio
93
94 %post -n %{name}-devel
95 /sbin/ldconfig
96
97 %postun -n %{name}-devel
98 /sbin/ldconfig
99
100 %files -n %{name}-devel
101 %defattr(-,root,root,-)
102 %{_includedir}/*
103 %{_libdir}/pkgconfig/*
104 %{_libdir}/lib*.la
105
106
107 %files -n %{name}
108 %defattr(-,root,root,-)
109 %{_bindir}/*
110 %dir /etc/gnuradio
111 %config /etc/gnuradio/*
112 %{_libdir}/lib*so*
113 %{_libdir}/python*/site-packages/
114 %{_datadir}/doc/*
115 %dir %{_datadir}/gnuradio
116 %{_datadir}/gnuradio/*
117 %dir %{_datadir}/usrp
118 %{_datadir}/usrp/*
119 # TO FIX: if the 2 following commands are removed, the rpmbuild fails!
120 # It's weird because rev2 and rev3 directories are indeed created at the 
121 # right place (/usr/share/rev*) when the rpm is installed...
122 %{_datadir}/rev2/*
123 %{_datadir}/rev4/*
124 %config(noreplace) %{_sysconfdir}/udev/rules.d/10-usrp.rules
125 %doc AUTHORS README README.hacking ChangeLog NEWS INSTALL COPYING
126
127
128
129 %changelog -n gnuradio
130 * Wed Oct 8 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.1
131 - fixed lots of missing parameters...
132
133 * Thu Oct 1 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.0
134 - derived from previous gnuradio-3.2 spec file written by Ben Yahmed Maher <ben.yahmed.maher@gmail.com>. Changes made to compile the new 3.2.2 gnuradio version on F10 with both USRP and USRP2 hardware enabled.
135
136 * Wed Apr 1 2009  Ben Yahmed Maher <ben.yahmed.maher@gmail.com> 3.2.2-1.2
137 - change to svn 10720 with fedora 10
138
139
140