Setting tag gnuradio-3.2.2-22
[gnuradio.git] / gnuradio.spec
1 # $Id$
2 # $URL$
3 #
4 %define name gnuradio
5 %define version 3.2.2
6 %define release 22
7 %define actual_name %{name}-%{version}
8
9 %define module_taglevel_varname release
10
11 Name: %{name}
12 Summary: GNU software radio
13 Version: %{version}
14 Release: %{release}
15 License: GPLv3
16 URL: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
17 Group: Productivity/Hamradio/Other
18 Source0: %{actual_name}.tar.gz
19 Source1:        10-usrp.rules
20 Patch0:         gnuradio-3.2-libtool.patch
21
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
23
24
25 BuildRequires: python python-numeric PyQt4 swig fftw sdcc gsl libtool 
26 BuildRequires: subversion guile cppunit gcc gcc-c++ make
27 BuildRequires: boost-devel >= 1.35
28 BuildRequires: python-devel fftw-devel boost-devel gsl-devel libusb-devel
29 BuildRequires: cppunit-devel
30
31
32 Requires: python python-numeric PyQt4 swig fftw libtool
33 Requires: boost >= 1.35
34
35 %description
36 gnuradio is a free software radio toolkit
37
38 %prep
39 %setup -q -n %{actual_name}
40 %patch0 -p1 -b .libtool
41
42
43 %build
44 export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
45 # dirty hack to let gnuradio configure find sdcc
46 export PATH=%{_libexecdir}/sdcc:$PATH
47
48 ########## the bootstrap script basically reruns autoconf and automake
49 %if "%{distro}" == "Fedora" && %{distrorelease} >= 12
50 autoreconf -i
51 %configure --disable-doxygen
52 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
53 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
54 make %{?_smp_mflags}
55 %else
56 bash -x ./bootstrap
57 %configure --disable-doxygen
58 make
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 make install DESTDIR=$RPM_BUILD_ROOT
64 install -D -m0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/10-usrp.rules
65
66 #make DESTDIR=$RPM_BUILD_ROOT install
67 %makeinstall
68
69 %post
70 echo 'export PYTHONPATH=/usr/lib/python2.5/site-packages/' >> ~/.bashrc
71 /sbin/ldconfig
72
73 %postun
74 /sbin/ldconfig
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79
80
81 %package -n %{name}-devel
82 Summary: gnuradio devel files
83 Version: %{version}
84 Release: %{release}
85 Group:   Productivity/Hamradio/Other
86 Requires: gnuradio
87
88 %description -n %{name}-devel
89 Devel package of gnuradio
90
91 %post -n %{name}-devel
92 /sbin/ldconfig
93
94 %postun -n %{name}-devel
95 /sbin/ldconfig
96
97 %files -n %{name}-devel
98 %defattr(-,root,root,-)
99 %{_includedir}/*
100 %{_libdir}/pkgconfig/*
101 %{_libdir}/lib*.la
102
103
104 %files -n %{name}
105 %defattr(-,root,root,-)
106 %{_bindir}/*
107 %dir /etc/gnuradio
108 %config /etc/gnuradio/*
109 %{_libdir}/lib*so*
110 %{_libdir}/python*/site-packages/
111 %{_datadir}/doc/*
112 %dir %{_datadir}/gnuradio
113 %{_datadir}/gnuradio/*
114 %dir %{_datadir}/usrp
115 %{_datadir}/usrp/*
116 # TO FIX: if the 2 following commands are removed, the rpmbuild fails!
117 # It's weird because rev2 and rev3 directories are indeed created at the 
118 # right place (/usr/share/rev*) when the rpm is installed...
119 %{_datadir}/rev2/*
120 %{_datadir}/rev4/*
121 %config(noreplace) %{_sysconfdir}/udev/rules.d/10-usrp.rules
122 %doc AUTHORS README README.hacking ChangeLog NEWS INSTALL COPYING
123
124
125
126 %changelog -n gnuradio
127 * Wed Jan 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - gnuradio-3.2.2-22
128 - reworked for f12
129
130 * Wed Oct 8 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.1
131 - fixed lots of missing parameters...
132
133 * Thu Oct 1 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.0
134 - derived from previous gnuradio-3.2 spec file written by Ben Yahmed Maher <ben.yahmed.maher@gmail.com>. Changes made to compile the new 3.2.2 gnuradio version on F10 with both USRP and USRP2 hardware enabled.
135
136 * Wed Apr 1 2009  Ben Yahmed Maher <ben.yahmed.maher@gmail.com> 3.2.2-1.2
137 - change to svn 10720 with fedora 10