use our own bootstrap procedure - on f12 for now
[gnuradio.git] / gnuradio.spec
1 # SPEC file for gnuradio
2 #
3 #
4 # Source: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
5 #
6 # Signature: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz.sig
7 #
8 %define name gnuradio
9 %define version 3.2.2
10 %define release 21
11 %define actual_name %{name}-%{version}
12
13 %define module_taglevel_varname release
14
15 Name: %{name}
16 Summary: GNU software radio
17 Version: %{version}
18 Release: %{release}
19 License: GPLv3
20 URL: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
21 Group: Productivity/Hamradio/Other
22 Source: %{actual_name}.tar.gz
23 Source1: bootstrap.wextoolbox
24
25 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
26
27
28 BuildRequires: python python-numeric PyQt4 swig fftw sdcc gsl libtool 
29 BuildRequires: subversion guile cppunit gcc gcc-c++ make
30 BuildRequires: boost-devel >= 1.35
31 BuildRequires: python-devel fftw-devel boost-devel gsl-devel libusb-devel
32 BuildRequires: cppunit-devel
33
34
35 Requires: python python-numeric PyQt4 swig fftw libtool
36 Requires: boost >= 1.35
37
38 %description
39 gnuradio is a free software radio toolkit
40
41 %prep
42
43 %setup -q -n %{actual_name}
44
45
46 %build
47 export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
48 # dirty hack to let gnuradio configure find sdcc
49 export PATH=$PATH:/usr/libexec/sdcc
50 # basically reruns autoconf and automake
51 %if "%{distro}" == "Fedora" && %{distrorelease} >= 12
52 bash -x ./bootstrap.wextoolbox
53 %else
54 bash -x ./bootstrap
55 %endif
56 %configure --disable-doxygen
57 make
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 mkdir $RPM_BUILD_ROOT
62
63 #make DESTDIR=$RPM_BUILD_ROOT install
64 %makeinstall
65
66 %post
67 echo 'export PYTHONPATH=/usr/lib/python2.5/site-packages/' >> ~/.bashrc
68 /sbin/ldconfig
69
70 %postun
71 /sbin/ldconfig
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76
77
78 %package -n %{name}-devel
79 Summary: gnuradio devel files
80 Version: %{version}
81 Release: %{release}
82 Group:   Productivity/Hamradio/Other
83 Requires: gnuradio
84
85 %description -n %{name}-devel
86 Devel package of gnuradio
87
88 %post -n %{name}-devel
89 /sbin/ldconfig
90
91 %postun -n %{name}-devel
92 /sbin/ldconfig
93
94 %files -n %{name}-devel
95 %defattr(-,root,root,-)
96 %{_includedir}/*
97 %{_libdir}/pkgconfig/*
98 %{_libdir}/lib*.la
99
100
101 %files -n %{name}
102 %defattr(-,root,root,-)
103 %{_bindir}/*
104 %dir /etc/gnuradio
105 %config /etc/gnuradio/*
106 %{_libdir}/lib*so*
107 %{_libdir}/python*/site-packages/
108 %{_datadir}/doc/*
109 %dir %{_datadir}/gnuradio
110 %{_datadir}/gnuradio/*
111 %dir %{_datadir}/usrp
112 %{_datadir}/usrp/*
113 # TO FIX: if the 2 following commands are removed, the rpmbuild fails!
114 # It's w+eird because rev2 and rev3 directories are indeed created at the 
115 # right place (/usr/share/rev*) when the rpm is installed...
116 %{_datadir}/rev2/*
117 %{_datadir}/rev4/*
118 %doc AUTHORS README README.hacking ChangeLog NEWS INSTALL COPYING
119
120
121
122
123
124 %changelog -n gnuradio
125 * Wed Oct 8 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.1
126 - fixed lots of missing parameters...
127
128 * Thu Oct 1 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.0
129 - derived from previous gnuradio-3.2 spec file written by Ben Yahmed Maher <ben.yahmed.maher@gmail.com>. Changes made to compile the new 3.2.2 gnuradio version on F10 with both USRP and USRP2 hardware enabled.
130
131 * Wed Apr 1 2009  Ben Yahmed Maher <ben.yahmed.maher@gmail.com> 3.2.2-1.2
132 - change to svn 10720 with fedora 10
133
134
135