another approach, patch bootstrap on the fly
[gnuradio.git] / gnuradio.spec
1 # SPEC file for gnuradio
2 #
3 #
4 # Source: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
5 #
6 # Signature: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz.sig
7 #
8 %define name gnuradio
9 %define version 3.2.2
10 %define release 21
11 %define actual_name %{name}-%{version}
12
13 %define module_taglevel_varname release
14
15 Name: %{name}
16 Summary: GNU software radio
17 Version: %{version}
18 Release: %{release}
19 License: GPLv3
20 URL: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
21 Group: Productivity/Hamradio/Other
22 Source: %{actual_name}.tar.gz
23
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
25
26
27 BuildRequires: python python-numeric PyQt4 swig fftw sdcc gsl libtool 
28 BuildRequires: subversion guile cppunit gcc gcc-c++ make
29 BuildRequires: boost-devel >= 1.35
30 BuildRequires: python-devel fftw-devel boost-devel gsl-devel libusb-devel
31 BuildRequires: cppunit-devel
32
33
34 Requires: python python-numeric PyQt4 swig fftw libtool
35 Requires: boost >= 1.35
36
37 %description
38 gnuradio is a free software radio toolkit
39
40 %prep
41 %setup -q -n %{actual_name}
42
43
44 %build
45 export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
46 # dirty hack to let gnuradio configure find sdcc
47 export PATH=$PATH:/usr/libexec/sdcc
48
49 ########## the bootstrap script basically reruns autoconf and automake
50 %if "%{distro}" == "Fedora" && %{distrorelease} >= 12
51 ### the code in bootstrapfs reads
52 ### aclocal -I config
53 # we suppress the -I config so that e.g. the libtool macros used are the ones from the system, 
54 # not the one that ships in config/
55 sed -i -e "s,aclocal -I config,aclocal," ./bootstrap
56 %endif
57
58 bash -x ./bootstrap
59
60 %configure --disable-doxygen
61 make
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 mkdir $RPM_BUILD_ROOT
66
67 #make DESTDIR=$RPM_BUILD_ROOT install
68 %makeinstall
69
70 %post
71 echo 'export PYTHONPATH=/usr/lib/python2.5/site-packages/' >> ~/.bashrc
72 /sbin/ldconfig
73
74 %postun
75 /sbin/ldconfig
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80
81
82 %package -n %{name}-devel
83 Summary: gnuradio devel files
84 Version: %{version}
85 Release: %{release}
86 Group:   Productivity/Hamradio/Other
87 Requires: gnuradio
88
89 %description -n %{name}-devel
90 Devel package of gnuradio
91
92 %post -n %{name}-devel
93 /sbin/ldconfig
94
95 %postun -n %{name}-devel
96 /sbin/ldconfig
97
98 %files -n %{name}-devel
99 %defattr(-,root,root,-)
100 %{_includedir}/*
101 %{_libdir}/pkgconfig/*
102 %{_libdir}/lib*.la
103
104
105 %files -n %{name}
106 %defattr(-,root,root,-)
107 %{_bindir}/*
108 %dir /etc/gnuradio
109 %config /etc/gnuradio/*
110 %{_libdir}/lib*so*
111 %{_libdir}/python*/site-packages/
112 %{_datadir}/doc/*
113 %dir %{_datadir}/gnuradio
114 %{_datadir}/gnuradio/*
115 %dir %{_datadir}/usrp
116 %{_datadir}/usrp/*
117 # TO FIX: if the 2 following commands are removed, the rpmbuild fails!
118 # It's w+eird because rev2 and rev3 directories are indeed created at the 
119 # right place (/usr/share/rev*) when the rpm is installed...
120 %{_datadir}/rev2/*
121 %{_datadir}/rev4/*
122 %doc AUTHORS README README.hacking ChangeLog NEWS INSTALL COPYING
123
124
125
126
127
128 %changelog -n gnuradio
129 * Wed Oct 8 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.1
130 - fixed lots of missing parameters...
131
132 * Thu Oct 1 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-2.0
133 - derived from previous gnuradio-3.2 spec file written by Ben Yahmed Maher <ben.yahmed.maher@gmail.com>. Changes made to compile the new 3.2.2 gnuradio version on F10 with both USRP and USRP2 hardware enabled.
134
135 * Wed Apr 1 2009  Ben Yahmed Maher <ben.yahmed.maher@gmail.com> 3.2.2-1.2
136 - change to svn 10720 with fedora 10
137
138
139