Tagging module inotify-tools - inotify-tools-3.13-2
[inotify-tools.git] / inotify-tools.spec
1 # $Id$
2 # Authority: dag
3
4 %define url $URL$
5
6 %define name inotify-tools
7 %define version 3.13
8 %define taglevel 2
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: Command line utilities for inotify
13 Name: %{name}
14 Version: %{version}
15 Release: %{taglevel}.rf
16 License: GPL
17 Group: Applications/System
18 URL: http://inotify-tools.sourceforge.net/
19
20 Packager: Dag Wieers <dag@wieers.com>
21 Vendor: Dag Apt Repository, http://dag.wieers.com/apt/
22
23 Source: http://dl.sf.net/inotify-tools/inotify-tools-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26 BuildRequires: autoconf
27 BuildRequires: doxygen
28
29 %description
30 inotify-tools is a set of command-line programs for Linux providing
31 a simple interface to inotify. These programs can be used to monitor
32 and act upon filesystem events.
33
34 %package devel
35 Summary: Header files, libraries and development documentation for %{name}.
36 Group: Development/Libraries
37 Requires: %{name} = %{version}-%{release}
38
39 %description devel
40 This package contains the header files, static libraries and development
41 documentation for %{name}. If you like to develop programs using %{name},
42 you will need to install %{name}-devel.
43
44 %prep
45 %setup
46
47 %build
48 %configure \
49     --disable-dependency-tracking \
50     --disable-static \
51     --enable-doxygen
52 %{__make} %{?_smp_mflags}
53
54 %install
55 %{__rm} -rf %{buildroot}
56 %{__make} install DESTDIR="%{buildroot}"
57
58 ### Clean up buildroot
59 %{__rm} -rf %{buildroot}%{_docdir}
60
61 %clean
62 %{__rm} -rf %{buildroot}
63
64 %post -p /sbin/ldconfig
65 %postun -p /sbin/ldconfig
66
67 %files
68 %defattr(-, root, root, 0755)
69 %doc AUTHORS ChangeLog COPYING NEWS README
70 %doc %{_mandir}/man1/inotifywait.1*
71 %doc %{_mandir}/man1/inotifywatch.1*
72 %{_bindir}/inotifywait
73 %{_bindir}/inotifywatch
74 %{_libdir}/libinotifytools.so.*
75
76 %files devel
77 %defattr(-, root, root, 0755)
78 %doc libinotifytools/src/doc/html/*
79 %{_includedir}/inotifytools/
80 %{_libdir}/libinotifytools.so
81 %exclude %{_libdir}/libinotifytools.la
82
83 %changelog
84 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - inotify-tools-3.13-2
85 - pull source tarball from planet-lab.org rather than onelab.eu
86
87 * Thu Mar 27 2008 Dag Wieers <dag@wieers.com> - 3.13-1 - +/
88 - Initial package. (using DAR)