7d84d90429e022ac4b9feb6b1898edadb425d8b4
[ipfw-sourceforge.git] / planetlab / ipfwroot.spec
1 #
2 # Marta Carbone <marta.carbone@iet.unipi.it>
3 # 2009 - Universita` di Pisa
4 # License is BSD.
5
6 # kernel_release, kernel_version and kernel_arch are expected to be set by the build to e.g.
7 # kernel_release : 24.onelab  (24 is then the planetlab taglevel)
8 # kernel_version : 2.6.27.57 | 2.6.32  (57 in the 27 case is the patch level)
9 # kernel_arch :    i686 | x86_64
10
11 # the 2012 release was pulled from http://info.iet.unipi.it/~marta/dummynet/ipfw3-20120610.tar.gz
12 # seel also          http://sourceforge.net/p/dummynet/code
13 # in 2013 Marta has moved to sourceforge at
14 # git clone git://git.code.sf.net/p/dummynet/code your read-only code
15 %define name ipfwroot
16 %define version 20130423
17 %define taglevel 0
18
19 # when no planetlab kernel is being built, kernel_version is defined but empty
20 %define _with_planetlab_kernel %{?kernel_version:1}%{!?kernel_version:0}
21 # we need to make sure that this rpm gets upgraded when the kernel release changes
22 %if %{_with_planetlab_kernel}
23 # with the planetlab kernel
24 %define pl_kernel_taglevel %( echo %{kernel_release} | cut -d. -f1 )
25 %define ipfw_release %{kernel_version}.%{pl_kernel_taglevel}
26 %else
27 # with the stock kernel
28 # this line below
29 #%define ipfw_release %( rpm -q --qf "%{version}" kernel-headers )
30 # causes recursive macro definition no matter how much you quote
31 %define percent %
32 %define braop \{
33 %define bracl \}
34 %define kernel_version %( rpm -q --qf %{percent}%{braop}version%{bracl} kernel-headers )
35 %define kernel_release %( rpm -q --qf %{percent}%{braop}release%{bracl} kernel-headers )
36 %define kernel_arch %( rpm -q --qf %{percent}%{braop}arch%{bracl} kernel-headers )
37 %define ipfw_release %{kernel_version}.%{kernel_release}
38 %endif
39
40 %define release %{ipfw_release}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
41
42 # guess which convention is used; k27 and before used dash, k32 uses dot
43 %define kernelpath_dash /usr/src/kernels/%{kernel_version}-%{kernel_release}-%{kernel_arch}
44 %define kernelpath_dot /usr/src/kernels/%{kernel_version}-%{kernel_release}.%{kernel_arch}
45 %define kernelpath %( [ -d %{kernelpath_dot} ] && echo %{kernelpath_dot} || echo %{kernelpath_dash} )
46
47 # the k32 kernel currently builds e.g. /lib/modules/2.6.32-0.onelab.2010.12.07-i686
48 # the k27 and before does not have the -i686 part
49 %define kernel_id_old %{kernel_version}-%{kernel_release}
50 %define kernel_id_new %{kernel_version}-%{kernel_release}.%{kernel_arch}
51 %define kernel_id %( [ -d %{kernelpath_dot} ] && echo %{kernel_id_new} || echo %{kernel_id_old} )
52
53 Summary: ipfw and dummynet for Linux
54 Name: %{name}
55 Version: %{version}
56 Release: %{release}
57 License: BSD
58 Group: System Environment/Kernel
59 Source0: %{name}-%{version}.tar.bz2
60 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
61 Requires: kernel = %{kernel_version}-%{kernel_release}
62 Requires: vixie-cron
63 Requires: vsys-scripts
64 Obsoletes: ipfw
65
66 Vendor: unipi
67 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
68 # XXX ask 
69 Distribution: PlanetLab %{plrelease}
70 URL: %{SCMURL}
71
72 %description
73 ipfw is the Linux port of the FreeBSD ipfw and dummynet packages
74
75 %prep
76 %setup
77
78 %build
79 # clean the rpm build directory
80 rm -rf $RPM_BUILD_ROOT
81
82 %__make KERNELPATH=%kernelpath clean
83 %__make KERNELPATH=%kernelpath IPFW_PLANETLAB=1
84
85 %install
86 install -D -m 755 dummynet2/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
87 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
88 install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
89 install -D -m 755 planetlab/ipfw $RPM_BUILD_ROOT/etc/rc.d/init.d/ipfw
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 ### this script is also triggered while the node image is being created at build-time
96 # some parts of the script do not make sense in this context
97 # this is why the build exports PL_BOOTCD=1 in such cases
98 depmod -a
99 /sbin/chkconfig --add ipfw
100 # start the service if not building
101 [ -z "$PL_BOOTCD" ] && service ipfw start
102
103 %postun
104 # stop the service if not building
105 [ -z "$PL_BOOTCD" ] && service ipfw stop
106
107 # here there is a list of the final installation directories
108 %files
109 %defattr(-,root,root)
110 %dir /lib/modules/%{kernel_id}
111 /lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
112 /sbin/ipfw
113 %{_sysconfdir}/cron.d/ipfw.cron
114 /etc/rc.d/init.d/ipfw
115
116 %changelog
117 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-20120610-2
118 - cosmetic changes only in specfile
119
120 * Fri Jun 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-20120610-1
121 - integrated ipfw3 as of 20120610 from upstream
122
123 * Mon Oct 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-23
124 - for building against k32 on f8
125
126 * Sun Oct 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-22
127 - rpm version number has the kernel taglevel embedded
128
129 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-21
130 - build tweaks for gcc-4.6 on f15
131
132 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-20
133 - tweaks for compiling on k32/64 bits
134
135 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-19
136 - fix detection of kernel conventions
137
138 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-18
139 - guess conventions for either <=k27 or >=k32
140
141 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-17
142 - testing git only module-tag
143
144 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
145 - tagging ipfw to test module-tools on (pure) git
146
147 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
148 - tagging for obsoletes
149
150 * Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
151 - Update to the ipfw3 version of the dummynet code.
152
153 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
154 - add ipfw initialization script to chkconfig
155
156 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
157 - - Load module at installation - Marta
158
159 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
160 - consistent with vsys-scripts-0.95-13
161
162 * Mon Jan 11 2010 Marta Carbone <marta.carbone@iet.unipi.it>
163 - Integrated the ipfw rules cleanup into the backend
164
165 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
166 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
167
168 * Wed Jan 06 2010 Marta Carbone <marta.carbone@iet.unipi.it>
169 - move to dummynet2, added support for table lookup
170 - added the vsys-script dependencies and the ipfw initialization
171
172 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
173 - more work on the radix code, added sysctl read/write support
174
175 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
176 - added missing qsort.c - tag 0.9-6 was broken
177
178 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
179 - root: removed goto into the main ipfw switch, enabled slice_id matching
180 - slice: completely move netconfig checks into the backend
181
182 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
183 - additional features on matching packets, including uid match
184
185 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
186 - on behalf of Marta Carbone, more options and features
187
188 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
189 - fixed memory usage issue
190
191 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
192 - patch for building on x86_64
193
194 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
195 - post installation removed for deployment, moved manpages to the slice package
196
197 * Fri Apr 17 2009 Marta Carbone <marta.carbone@iet.unipi.it>
198 - Initial release