2a8daab32381770cbc215621f9ac3444f69ae4ad
[ipfw.git] / ipfw-slice.spec
1 #
2 # $Id$
3 #
4 # TODO:
5 # restart crond
6 # modprobe ipfw_mod.ko (depmod ?)
7 #
8 %define url $URL: http://onelab1.iet.unipi.it/svn/trunk/ipfw-slice.spec $
9
10 # Marta Carbone <marta.carbone@iet.unipi.it>
11 # 2009 - Universita` di Pisa
12 # License is BSD.
13
14 %define name ipfw-slice
15 %define version 0.9
16 %define taglevel 6
17
18 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
19 %define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
20 %define kernel_id %{kernel_version}-%{kernel_release}
21
22 Summary: ipfw and dummynet for Linux
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Kernel
28 Source0: %{name}-%{version}.tar.bz2
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
30
31 Vendor: unipi
32 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
33 Distribution: PlanetLab %{plrelease}
34 URL: %(echo %{url} | cut -d ' ' -f 2)
35
36 %description
37 the frontent part of the ipfw planetlab package
38
39 %prep
40 %setup
41
42 %build
43 rm -rf $RPM_BUILD_ROOT
44
45 %install
46 install -D -m 755 slice/netconfig $RPM_BUILD_ROOT/sbin/netconfig
47 install -D -m 755 slice/ipfw.8.gz $RPM_BUILD_ROOT/%{_mandir}/man8/ipfw.8.gz
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 # here there is a list of the final installation directories
53 %files
54 %defattr(-,root,root)
55 /sbin/netconfig
56 %{_mandir}/man8/ipfw.8*
57
58 %changelog
59 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
60 - root: removed goto into the main ipfw switch, enabled slice_id matching
61 - slice: completely move netconfig checks into the backend
62
63 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
64 - additional features on matching packets, including uid match
65
66 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
67 - on behalf of Marta Carbone, more options and features
68
69 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
70 - fixed memory usage issue
71
72 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
73 - patch for building on x86_64
74
75 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
76 - Initial release