Setting tag ipfw-0.9-7
[ipfw.git] / ipfw.spec
1 #
2 # $Id$
3 #
4 # TODO:
5 # restart crond
6 # modprobe ipfw_mod.ko (depmod ?)
7 #
8 %define url $URL: http://onelab1.iet.unipi.it/svn/trunk/ipfw.spec $
9
10 # Marta Carbone <marta.carbone@iet.unipi.it>
11 # 2009 - Universita` di Pisa
12 # License is BSD.
13
14 # kernel_release, kernel_version and kernel_arch are expected to be set by the build to e.g.
15 # kernel_release : vs2.3.0.29.1.planetlab
16 # kernel_version : 2.6.22.14
17
18 %define name ipfw
19 %define version 0.9
20 %define taglevel 7
21
22 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
23 %define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
24 %define kernel_id %{kernel_version}-%{kernel_release}
25
26 Summary: ipfw and dummynet for Linux
27 Name: %{name}
28 Version: %{version}
29 Release: %{release}
30 License: BSD
31 Group: System Environment/Kernel
32 Source0: %{name}-%{version}.tar.bz2
33 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
34 Requires: vixie-cron
35
36 Vendor: unipi
37 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
38 # XXX ask 
39 Distribution: PlanetLab %{plrelease}
40 URL: %(echo %{url} | cut -d ' ' -f 2)
41
42 %description
43 ipfw is the Linux port of the FreeBSD ipfw and dummynet packages
44
45 %prep
46 %setup
47
48 %build
49 # clean the rpm build directory
50
51 rm -rf $RPM_BUILD_ROOT
52
53 # with the new build, we use the kernel-devel rpm for building
54 %define kernelpath /usr/src/kernels/%{kernel_id_arch}
55
56 %__make KERNELPATH=%kernelpath clean
57 %__make KERNELPATH=%kernelpath IPFW_PLANETLAB=1
58
59 %install
60 install -D -m 755 dummynet/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
61 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
62 install -D -m 755 ipfw-cleanup $RPM_BUILD_ROOT/usr/bin/ipfw-cleanup
63 install -D -m 755 ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 # here there is a list of the final installation directories
69 %files
70 %defattr(-,root,root)
71 %dir /lib/modules/%{kernel_id}
72 /lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
73 /sbin/ipfw
74 /usr/bin/ipfw-cleanup
75 %{_sysconfdir}/cron.d/ipfw.cron
76
77 %changelog
78 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
79 - added missing qsort.c - tag 0.9-6 was broken
80
81 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
82 - root: removed goto into the main ipfw switch, enabled slice_id matching
83 - slice: completely move netconfig checks into the backend
84
85 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
86 - additional features on matching packets, including uid match
87
88 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
89 - on behalf of Marta Carbone, more options and features
90
91 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
92 - fixed memory usage issue
93
94 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
95 - patch for building on x86_64
96
97 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
98 - post installation removed for deployment, moved manpages to the slice package
99 * Fri Apr 17 2009 Marta Carbone <marta.carbone@iet.unipi.it>
100 - Initial release