fixed specfile to be able to run against stock kernel (in which case
[ipfw.git] / planetlab / ipfwroot.spec
1 #
2 # Marta Carbone <marta.carbone@iet.unipi.it>
3 # 2009 - Universita` di Pisa
4 # License is BSD.
5
6 #
7 # xxx: TODO restart crond
8 #
9
10 # kernel_release, kernel_version and kernel_arch are expected to be set by the build to e.g.
11 # kernel_release : 24.onelab  (24 is then the planetlab taglevel)
12 # kernel_version : 2.6.27.57 | 2.6.32  (57 in the 27 case is the patch level)
13 # kernel_arch :    i686 | x86_64
14
15 %define name ipfwroot
16 %define version 20120610
17 %define taglevel 1
18
19 # when no planetlab kernel is being built, kernel_version is defined but empty
20 %define _with_planetlab_kernel %{?kernel_version:1}%{!?kernel_version:0}
21 # we need to make sure that this rpm gets upgraded when the kernel release changes
22 %if %{_with_planetlab_kernel}
23 # with the planetlab kernel
24 %define pl_kernel_taglevel %( echo %{kernel_release} | cut -d. -f1 )
25 %define ipfw_release %{kernel_version}.%{pl_kernel_taglevel}
26 %else
27 # with the stock kernel
28 # this line below
29 #%define ipfw_release %( rpm -q --qf "%{version}" kernel-headers )
30 # causes recursive macro definition no matter how much you quote
31 %define percent %
32 %define braop \{
33 %define bracl \}
34 %define kernel_version %( rpm -q --qf %{percent}%{braop}version%{bracl} kernel-headers )
35 %define kernel_release %( rpm -q --qf %{percent}%{braop}release%{bracl} kernel-headers )
36 %define kernel_arch %( rpm -q --qf %{percent}%{braop}arch%{bracl} kernel-headers )
37 %define ipfw_release %{kernel_version}.%{kernel_release}
38 %endif
39
40 %define release %{ipfw_release}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
41
42 # guess which convention is used; k27 and before used dash, k32 uses dot
43 %define kernelpath_dash /usr/src/kernels/%{kernel_version}-%{kernel_release}-%{kernel_arch}
44 %define kernelpath_dot /usr/src/kernels/%{kernel_version}-%{kernel_release}.%{kernel_arch}
45 %define kernelpath %( [ -d %{kernelpath_dot} ] && echo %{kernelpath_dot} || echo %{kernelpath_dash} )
46
47 # the k32 kernel currently builds e.g. /lib/modules/2.6.32-0.onelab.2010.12.07-i686
48 # the k27 and before does not have the -i686 part
49 %define kernel_id_old %{kernel_version}-%{kernel_release}
50 %define kernel_id_new %{kernel_version}-%{kernel_release}.%{kernel_arch}
51 %define kernel_id %( [ -d %{kernelpath_dot} ] && echo %{kernel_id_new} || echo %{kernel_id_old} )
52
53 Summary: ipfw and dummynet for Linux
54 Name: %{name}
55 Version: %{version}
56 Release: %{release}
57 License: BSD
58 Group: System Environment/Kernel
59 Source0: %{name}-%{version}.tar.bz2
60 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
61 Requires: vixie-cron
62 Requires: vsys-scripts
63 Obsoletes: ipfw
64
65 Vendor: unipi
66 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
67 # XXX ask 
68 Distribution: PlanetLab %{plrelease}
69 URL: %{SCMURL}
70
71 %description
72 ipfw is the Linux port of the FreeBSD ipfw and dummynet packages
73
74 %prep
75 %setup
76
77 %build
78 # clean the rpm build directory
79 rm -rf $RPM_BUILD_ROOT
80
81 %__make KERNELPATH=%kernelpath clean
82 %__make KERNELPATH=%kernelpath IPFW_PLANETLAB=1
83
84 %install
85 install -D -m 755 dummynet2/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
86 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
87 install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
88 install -D -m 755 planetlab/ipfw $RPM_BUILD_ROOT/etc/rc.d/init.d/ipfw
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 ### this script is also triggered while the node image is being created at build-time
95 # some parts of the script do not make sense in this context
96 # this is why the build exports PL_BOOTCD=1 in such cases
97 depmod -a
98 /sbin/chkconfig --add ipfw
99 # start the service if not building
100 [ -z "$PL_BOOTCD" ] && service ipfw start
101
102 %postun
103 # stop the service if not building
104 [ -z "$PL_BOOTCD" ] && service ipfw stop
105
106 # here there is a list of the final installation directories
107 %files
108 %defattr(-,root,root)
109 %dir /lib/modules/%{kernel_id}
110 /lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
111 /sbin/ipfw
112 %{_sysconfdir}/cron.d/ipfw.cron
113 /etc/rc.d/init.d/ipfw
114
115 %changelog
116 * Mon Oct 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-23
117 - for building against k32 on f8
118
119 * Sun Oct 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-22
120 - rpm version number has the kernel taglevel embedded
121
122 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-21
123 - build tweaks for gcc-4.6 on f15
124
125 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-20
126 - tweaks for compiling on k32/64 bits
127
128 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-19
129 - fix detection of kernel conventions
130
131 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-18
132 - guess conventions for either <=k27 or >=k32
133
134 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-17
135 - testing git only module-tag
136
137 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
138 - tagging ipfw to test module-tools on (pure) git
139
140 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
141 - tagging for obsoletes
142
143 * Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
144 - Update to the ipfw3 version of the dummynet code.
145
146 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
147 - add ipfw initialization script to chkconfig
148
149 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
150 - - Load module at installation - Marta
151
152 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
153 - consistent with vsys-scripts-0.95-13
154
155 * Mon Jan 11 2010 Marta Carbone <marta.carbone@iet.unipi.it>
156 - Integrated the ipfw rules cleanup into the backend
157
158 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
159 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
160
161 * Wed Jan 06 2010 Marta Carbone <marta.carbone@iet.unipi.it>
162 - move to dummynet2, added support for table lookup
163 - added the vsys-script dependencies and the ipfw initialization
164
165 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
166 - more work on the radix code, added sysctl read/write support
167
168 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
169 - added missing qsort.c - tag 0.9-6 was broken
170
171 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
172 - root: removed goto into the main ipfw switch, enabled slice_id matching
173 - slice: completely move netconfig checks into the backend
174
175 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
176 - additional features on matching packets, including uid match
177
178 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
179 - on behalf of Marta Carbone, more options and features
180
181 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
182 - fixed memory usage issue
183
184 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
185 - patch for building on x86_64
186
187 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
188 - post installation removed for deployment, moved manpages to the slice package
189
190 * Fri Apr 17 2009 Marta Carbone <marta.carbone@iet.unipi.it>
191 - Initial release