add a mention to Marta's sourceforge repo
[ipfw.git] / planetlab / ipfwroot.spec
1 #
2 # Marta Carbone <marta.carbone@iet.unipi.it>
3 # 2009 - Universita` di Pisa
4 # License is BSD.
5
6 #
7 # xxx: TODO restart crond
8 #
9
10 # kernel_release, kernel_version and kernel_arch are expected to be set by the build to e.g.
11 # kernel_release : 24.onelab  (24 is then the planetlab taglevel)
12 # kernel_version : 2.6.27.57 | 2.6.32  (57 in the 27 case is the patch level)
13 # kernel_arch :    i686 | x86_64
14
15 # this release was pulled from http://info.iet.unipi.it/~marta/dummynet/ipfw3-20120610.tar.gz
16 # seel also          http://sourceforge.net/p/dummynet/code
17 %define name ipfwroot
18 %define version 20120610
19 %define taglevel 1
20
21 # when no planetlab kernel is being built, kernel_version is defined but empty
22 %define _with_planetlab_kernel %{?kernel_version:1}%{!?kernel_version:0}
23 # we need to make sure that this rpm gets upgraded when the kernel release changes
24 %if %{_with_planetlab_kernel}
25 # with the planetlab kernel
26 %define pl_kernel_taglevel %( echo %{kernel_release} | cut -d. -f1 )
27 %define ipfw_release %{kernel_version}.%{pl_kernel_taglevel}
28 %else
29 # with the stock kernel
30 # this line below
31 #%define ipfw_release %( rpm -q --qf "%{version}" kernel-headers )
32 # causes recursive macro definition no matter how much you quote
33 %define percent %
34 %define braop \{
35 %define bracl \}
36 %define kernel_version %( rpm -q --qf %{percent}%{braop}version%{bracl} kernel-headers )
37 %define kernel_release %( rpm -q --qf %{percent}%{braop}release%{bracl} kernel-headers )
38 %define kernel_arch %( rpm -q --qf %{percent}%{braop}arch%{bracl} kernel-headers )
39 %define ipfw_release %{kernel_version}.%{kernel_release}
40 %endif
41
42 %define release %{ipfw_release}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
43
44 # guess which convention is used; k27 and before used dash, k32 uses dot
45 %define kernelpath_dash /usr/src/kernels/%{kernel_version}-%{kernel_release}-%{kernel_arch}
46 %define kernelpath_dot /usr/src/kernels/%{kernel_version}-%{kernel_release}.%{kernel_arch}
47 %define kernelpath %( [ -d %{kernelpath_dot} ] && echo %{kernelpath_dot} || echo %{kernelpath_dash} )
48
49 # the k32 kernel currently builds e.g. /lib/modules/2.6.32-0.onelab.2010.12.07-i686
50 # the k27 and before does not have the -i686 part
51 %define kernel_id_old %{kernel_version}-%{kernel_release}
52 %define kernel_id_new %{kernel_version}-%{kernel_release}.%{kernel_arch}
53 %define kernel_id %( [ -d %{kernelpath_dot} ] && echo %{kernel_id_new} || echo %{kernel_id_old} )
54
55 Summary: ipfw and dummynet for Linux
56 Name: %{name}
57 Version: %{version}
58 Release: %{release}
59 License: BSD
60 Group: System Environment/Kernel
61 Source0: %{name}-%{version}.tar.bz2
62 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
63 Requires: vixie-cron
64 Requires: vsys-scripts
65 Obsoletes: ipfw
66
67 Vendor: unipi
68 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
69 # XXX ask 
70 Distribution: PlanetLab %{plrelease}
71 URL: %{SCMURL}
72
73 %description
74 ipfw is the Linux port of the FreeBSD ipfw and dummynet packages
75
76 %prep
77 %setup
78
79 %build
80 # clean the rpm build directory
81 rm -rf $RPM_BUILD_ROOT
82
83 %__make KERNELPATH=%kernelpath clean
84 %__make KERNELPATH=%kernelpath IPFW_PLANETLAB=1
85
86 %install
87 install -D -m 755 dummynet2/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
88 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
89 install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
90 install -D -m 755 planetlab/ipfw $RPM_BUILD_ROOT/etc/rc.d/init.d/ipfw
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post
96 ### this script is also triggered while the node image is being created at build-time
97 # some parts of the script do not make sense in this context
98 # this is why the build exports PL_BOOTCD=1 in such cases
99 depmod -a
100 /sbin/chkconfig --add ipfw
101 # start the service if not building
102 [ -z "$PL_BOOTCD" ] && service ipfw start
103
104 %postun
105 # stop the service if not building
106 [ -z "$PL_BOOTCD" ] && service ipfw stop
107
108 # here there is a list of the final installation directories
109 %files
110 %defattr(-,root,root)
111 %dir /lib/modules/%{kernel_id}
112 /lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
113 /sbin/ipfw
114 %{_sysconfdir}/cron.d/ipfw.cron
115 /etc/rc.d/init.d/ipfw
116
117 %changelog
118 * Fri Jun 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-20120610-1
119 - integrated ipfw3 as of 20120610 from upstream
120
121 * Mon Oct 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-23
122 - for building against k32 on f8
123
124 * Sun Oct 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-22
125 - rpm version number has the kernel taglevel embedded
126
127 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-21
128 - build tweaks for gcc-4.6 on f15
129
130 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-20
131 - tweaks for compiling on k32/64 bits
132
133 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-19
134 - fix detection of kernel conventions
135
136 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-18
137 - guess conventions for either <=k27 or >=k32
138
139 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-17
140 - testing git only module-tag
141
142 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
143 - tagging ipfw to test module-tools on (pure) git
144
145 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
146 - tagging for obsoletes
147
148 * Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
149 - Update to the ipfw3 version of the dummynet code.
150
151 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
152 - add ipfw initialization script to chkconfig
153
154 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
155 - - Load module at installation - Marta
156
157 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
158 - consistent with vsys-scripts-0.95-13
159
160 * Mon Jan 11 2010 Marta Carbone <marta.carbone@iet.unipi.it>
161 - Integrated the ipfw rules cleanup into the backend
162
163 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
164 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
165
166 * Wed Jan 06 2010 Marta Carbone <marta.carbone@iet.unipi.it>
167 - move to dummynet2, added support for table lookup
168 - added the vsys-script dependencies and the ipfw initialization
169
170 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
171 - more work on the radix code, added sysctl read/write support
172
173 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
174 - added missing qsort.c - tag 0.9-6 was broken
175
176 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
177 - root: removed goto into the main ipfw switch, enabled slice_id matching
178 - slice: completely move netconfig checks into the backend
179
180 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
181 - additional features on matching packets, including uid match
182
183 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
184 - on behalf of Marta Carbone, more options and features
185
186 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
187 - fixed memory usage issue
188
189 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
190 - patch for building on x86_64
191
192 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
193 - post installation removed for deployment, moved manpages to the slice package
194
195 * Fri Apr 17 2009 Marta Carbone <marta.carbone@iet.unipi.it>
196 - Initial release