This repo is obsolete, please see git://git.code.sf.net/p/dummynet/code@master
[ipfw.git] / planetlab / ipfwroot.spec
1 #
2 # This repository is obsolete - please see instead
3 # git://git.code.sf.net/p/dummynet/code@master
4 #
5 # Marta Carbone <marta.carbone@iet.unipi.it>
6 # 2009 - Universita` di Pisa
7 # License is BSD.
8
9 #
10 # xxx: TODO restart crond
11 #
12
13 # kernel_release, kernel_version and kernel_arch are expected to be set by the build to e.g.
14 # kernel_release : 24.onelab  (24 is then the planetlab taglevel)
15 # kernel_version : 2.6.27.57 | 2.6.32  (57 in the 27 case is the patch level)
16 # kernel_arch :    i686 | x86_64
17
18 # this release was pulled from http://info.iet.unipi.it/~marta/dummynet/ipfw3-20120610.tar.gz
19 # seel also          http://sourceforge.net/p/dummynet/code
20 %define name ipfwroot
21 %define version 20120610
22 %define taglevel 2
23
24 # when no planetlab kernel is being built, kernel_version is defined but empty
25 %define _with_planetlab_kernel %{?kernel_version:1}%{!?kernel_version:0}
26 # we need to make sure that this rpm gets upgraded when the kernel release changes
27 %if %{_with_planetlab_kernel}
28 # with the planetlab kernel
29 %define pl_kernel_taglevel %( echo %{kernel_release} | cut -d. -f1 )
30 %define ipfw_release %{kernel_version}.%{pl_kernel_taglevel}
31 %else
32 # with the stock kernel
33 # this line below
34 #%define ipfw_release %( rpm -q --qf "%{version}" kernel-headers )
35 # causes recursive macro definition no matter how much you quote
36 %define percent %
37 %define braop \{
38 %define bracl \}
39 %define kernel_version %( rpm -q --qf %{percent}%{braop}version%{bracl} kernel-headers )
40 %define kernel_release %( rpm -q --qf %{percent}%{braop}release%{bracl} kernel-headers )
41 %define kernel_arch %( rpm -q --qf %{percent}%{braop}arch%{bracl} kernel-headers )
42 %define ipfw_release %{kernel_version}.%{kernel_release}
43 %endif
44
45 %define release %{ipfw_release}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
46
47 # guess which convention is used; k27 and before used dash, k32 uses dot
48 %define kernelpath_dash /usr/src/kernels/%{kernel_version}-%{kernel_release}-%{kernel_arch}
49 %define kernelpath_dot /usr/src/kernels/%{kernel_version}-%{kernel_release}.%{kernel_arch}
50 %define kernelpath %( [ -d %{kernelpath_dot} ] && echo %{kernelpath_dot} || echo %{kernelpath_dash} )
51
52 # the k32 kernel currently builds e.g. /lib/modules/2.6.32-0.onelab.2010.12.07-i686
53 # the k27 and before does not have the -i686 part
54 %define kernel_id_old %{kernel_version}-%{kernel_release}
55 %define kernel_id_new %{kernel_version}-%{kernel_release}.%{kernel_arch}
56 %define kernel_id %( [ -d %{kernelpath_dot} ] && echo %{kernel_id_new} || echo %{kernel_id_old} )
57
58 Summary: ipfw and dummynet for Linux
59 Name: %{name}
60 Version: %{version}
61 Release: %{release}
62 License: BSD
63 Group: System Environment/Kernel
64 Source0: %{name}-%{version}.tar.bz2
65 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
66 Requires: kernel = %{kernel_version}-%{kernel_release}
67 Requires: vixie-cron
68 Requires: vsys-scripts
69 Obsoletes: ipfw
70
71 Vendor: unipi
72 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
73 # XXX ask 
74 Distribution: PlanetLab %{plrelease}
75 URL: %{SCMURL}
76
77 %description
78 ipfw is the Linux port of the FreeBSD ipfw and dummynet packages
79
80 %prep
81 %setup
82
83 %build
84 # clean the rpm build directory
85 rm -rf $RPM_BUILD_ROOT
86
87 %__make KERNELPATH=%kernelpath clean
88 %__make KERNELPATH=%kernelpath IPFW_PLANETLAB=1
89
90 %install
91 install -D -m 755 dummynet2/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
92 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
93 install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
94 install -D -m 755 planetlab/ipfw $RPM_BUILD_ROOT/etc/rc.d/init.d/ipfw
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 ### this script is also triggered while the node image is being created at build-time
101 # some parts of the script do not make sense in this context
102 # this is why the build exports PL_BOOTCD=1 in such cases
103 depmod -a
104 /sbin/chkconfig --add ipfw
105 # start the service if not building
106 [ -z "$PL_BOOTCD" ] && service ipfw start
107
108 %postun
109 # stop the service if not building
110 [ -z "$PL_BOOTCD" ] && service ipfw stop
111
112 # here there is a list of the final installation directories
113 %files
114 %defattr(-,root,root)
115 %dir /lib/modules/%{kernel_id}
116 /lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
117 /sbin/ipfw
118 %{_sysconfdir}/cron.d/ipfw.cron
119 /etc/rc.d/init.d/ipfw
120
121 %changelog
122 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-20120610-2
123 - cosmetic changes only in specfile
124
125 * Fri Jun 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-20120610-1
126 - integrated ipfw3 as of 20120610 from upstream
127
128 * Mon Oct 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-23
129 - for building against k32 on f8
130
131 * Sun Oct 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-22
132 - rpm version number has the kernel taglevel embedded
133
134 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-21
135 - build tweaks for gcc-4.6 on f15
136
137 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-20
138 - tweaks for compiling on k32/64 bits
139
140 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-19
141 - fix detection of kernel conventions
142
143 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-18
144 - guess conventions for either <=k27 or >=k32
145
146 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-17
147 - testing git only module-tag
148
149 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
150 - tagging ipfw to test module-tools on (pure) git
151
152 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
153 - tagging for obsoletes
154
155 * Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
156 - Update to the ipfw3 version of the dummynet code.
157
158 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
159 - add ipfw initialization script to chkconfig
160
161 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
162 - - Load module at installation - Marta
163
164 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
165 - consistent with vsys-scripts-0.95-13
166
167 * Mon Jan 11 2010 Marta Carbone <marta.carbone@iet.unipi.it>
168 - Integrated the ipfw rules cleanup into the backend
169
170 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
171 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
172
173 * Wed Jan 06 2010 Marta Carbone <marta.carbone@iet.unipi.it>
174 - move to dummynet2, added support for table lookup
175 - added the vsys-script dependencies and the ipfw initialization
176
177 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
178 - more work on the radix code, added sysctl read/write support
179
180 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
181 - added missing qsort.c - tag 0.9-6 was broken
182
183 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
184 - root: removed goto into the main ipfw switch, enabled slice_id matching
185 - slice: completely move netconfig checks into the backend
186
187 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
188 - additional features on matching packets, including uid match
189
190 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
191 - on behalf of Marta Carbone, more options and features
192
193 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
194 - fixed memory usage issue
195
196 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
197 - patch for building on x86_64
198
199 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
200 - post installation removed for deployment, moved manpages to the slice package
201
202 * Fri Apr 17 2009 Marta Carbone <marta.carbone@iet.unipi.it>
203 - Initial release