add a mention to Marta's sourceforge repo
[ipfw.git] / planetlab / ipfwslice.spec
1 #
2 # TODO:
3 # restart crond
4 # modprobe ipfw_mod.ko (depmod ?)
5 #
6
7 # Marta Carbone <marta.carbone@iet.unipi.it>
8 # 2009 - Universita` di Pisa
9 # License is BSD.
10
11 # this release was pulled from http://info.iet.unipi.it/~marta/dummynet/ipfw3-20120610.tar.gz
12 # seel also          http://sourceforge.net/p/dummynet/code
13 %define name ipfwslice
14 %define version 20120610
15 %define taglevel 1
16
17 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
18 %define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
19 %define kernel_id %{kernel_version}-%{kernel_release}
20
21 Summary: ipfw and dummynet for Linux
22 Name: %{name}
23 Version: %{version}
24 Release: %{release}
25 License: BSD
26 Group: System Environment/Kernel
27 Source0: %{name}-%{version}.tar.bz2
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29
30 Vendor: unipi
31 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
32 Distribution: PlanetLab %{plrelease}
33 URL: %{SCMURL}
34
35 %description
36 the frontend part of the ipfw planetlab package
37
38 %prep
39 %setup
40
41 %build
42 rm -rf $RPM_BUILD_ROOT
43
44 %install
45 install -D -m 755 planetlab/netconfig $RPM_BUILD_ROOT/sbin/netconfig
46 install -D -m 755 planetlab/ipfw.8.gz $RPM_BUILD_ROOT/%{_mandir}/man8/ipfw.8.gz
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 # here there is a list of the final installation directories
52 %files
53 %defattr(-,root,root)
54 /sbin/netconfig
55 %{_mandir}/man8/ipfw.8*
56
57 %changelog
58 * Fri Jun 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-20120610-1
59 - integrated ipfw3 as of 20120610 from upstream
60
61 * Mon Oct 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-23
62 - for building against k32 on f8
63
64 * Sun Oct 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-22
65 - rpm version number has the kernel taglevel embedded
66
67 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-21
68 - build tweaks for gcc-4.6 on f15
69
70 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-20
71 - tweaks for compiling on k32/64 bits
72
73 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-19
74 - fix detection of kernel conventions
75
76 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-18
77 - guess conventions for either <=k27 or >=k32
78
79 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-17
80 - testing git only module-tag
81
82 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
83 - tagging ipfw to test module-tools on (pure) git
84
85 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
86 - tagging for obsoletes
87
88 * Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
89 - Update to the ipfw3 version of the dummynet code.
90
91 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
92 - add ipfw initialization script to chkconfig
93
94 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
95 - - Load module at installation - Marta
96
97 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
98 - consistent with vsys-scripts-0.95-13
99
100 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
101 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
102
103 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
104 - more work on the radix code, added sysctl read/write support
105
106 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
107 - added missing qsort.c - tag 0.9-6 was broken
108
109 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
110 - root: removed goto into the main ipfw switch, enabled slice_id matching
111 - slice: completely move netconfig checks into the backend
112
113 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
114 - additional features on matching packets, including uid match
115
116 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
117 - on behalf of Marta Carbone, more options and features
118
119 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
120 - fixed memory usage issue
121
122 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
123 - patch for building on x86_64
124
125 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
126 - Initial release