4b262bc43f9dbcd6556fe182e9ac6e320a2ee5f9
[ipfw.git] / planetlab / ipfwslice.spec
1 #
2 # TODO:
3 # restart crond
4 # modprobe ipfw_mod.ko (depmod ?)
5 #
6
7 # Marta Carbone <marta.carbone@iet.unipi.it>
8 # 2009 - Universita` di Pisa
9 # License is BSD.
10
11 # this release was pulled from http://info.iet.unipi.it/~marta/dummynet/ipfw3-20120610.tar.gz
12 # seel also          http://sourceforge.net/p/dummynet/code
13 %define name ipfwslice
14 %define version 20120610
15 %define taglevel 1
16
17 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
18
19 Summary: ipfw and dummynet for Linux
20 Name: %{name}
21 Version: %{version}
22 Release: %{release}
23 License: BSD
24 Group: System Environment/Kernel
25 Source0: %{name}-%{version}.tar.bz2
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27
28 Vendor: unipi
29 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
30 Distribution: PlanetLab %{plrelease}
31 URL: %{SCMURL}
32
33 %description
34 the frontend part of the ipfw planetlab package
35
36 %prep
37 %setup
38
39 %build
40 rm -rf $RPM_BUILD_ROOT
41
42 %install
43 install -D -m 755 planetlab/netconfig $RPM_BUILD_ROOT/sbin/netconfig
44 install -D -m 755 planetlab/ipfw.8.gz $RPM_BUILD_ROOT/%{_mandir}/man8/ipfw.8.gz
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 # here there is a list of the final installation directories
50 %files
51 %defattr(-,root,root)
52 /sbin/netconfig
53 %{_mandir}/man8/ipfw.8*
54
55 %changelog
56 * Fri Jun 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-20120610-1
57 - integrated ipfw3 as of 20120610 from upstream
58
59 * Mon Oct 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-23
60 - for building against k32 on f8
61
62 * Sun Oct 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-22
63 - rpm version number has the kernel taglevel embedded
64
65 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-21
66 - build tweaks for gcc-4.6 on f15
67
68 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-20
69 - tweaks for compiling on k32/64 bits
70
71 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-19
72 - fix detection of kernel conventions
73
74 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-18
75 - guess conventions for either <=k27 or >=k32
76
77 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-17
78 - testing git only module-tag
79
80 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
81 - tagging ipfw to test module-tools on (pure) git
82
83 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
84 - tagging for obsoletes
85
86 * Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
87 - Update to the ipfw3 version of the dummynet code.
88
89 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
90 - add ipfw initialization script to chkconfig
91
92 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
93 - - Load module at installation - Marta
94
95 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
96 - consistent with vsys-scripts-0.95-13
97
98 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
99 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
100
101 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
102 - more work on the radix code, added sysctl read/write support
103
104 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
105 - added missing qsort.c - tag 0.9-6 was broken
106
107 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
108 - root: removed goto into the main ipfw switch, enabled slice_id matching
109 - slice: completely move netconfig checks into the backend
110
111 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
112 - additional features on matching packets, including uid match
113
114 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
115 - on behalf of Marta Carbone, more options and features
116
117 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
118 - fixed memory usage issue
119
120 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
121 - patch for building on x86_64
122
123 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
124 - Initial release